Safari/Facebook problems

Discussion in 'Mac Basics and Help' started by Ozman712, Feb 5, 2008.

  1. macrumors member

    Joined:
    Mar 6, 2006
    #1
    I am having issues with Facebook on Safari. Over the past few months Facebook does not act correctly when I load it into Safari. The main issues are Safari no longer stores my FB password. I have cleared it from my keychain, but it will not give me a prompt to save it again. Second, when I am logged into my account, the search box's submit button on the top left will not work (it will not recognize it as a button) and this happens throughout various FB pages with other buttons. Lastly, it will log me out and I will relog in and it will not let me log in, it just keeps kicking back to the log in page.

    I can open and operate FB in both Firefox and Camino without a problem. I don't know what is causing this. It just happens with FB and no other sites. I do have AdBlock, but this started to happen before I installed that. Any ideas or fixes would be greatly appreciated.

    Thanks,
    Oz
     
  2. macrumors 68000

    kuebby

    Joined:
    Jan 18, 2007
    Location:
    SFV
    #2
    It's happening to me too, and I have absolutely no idea why. Restarting Safari seems to fix the problem though, at least until the next time.
     
  3. thread starter macrumors member

    Joined:
    Mar 6, 2006
    #3
    Im glad to hear it isn't only me. I hate to restart Safari because I usually have a ton of stuff open and it is a hassle. Plus, it is only temporary at best. Wonder if there are any solutions?
     
  4. macrumors 68020

    JML42691

    Joined:
    Oct 24, 2007
    #4
    I do not have a problem with it, are you using the click box to store your password, or having Safari save it.?
     
  5. thread starter macrumors member

    Joined:
    Mar 6, 2006
    #5
    I have Safari save it. I know this is probably a pretty isolated problem because I have friends that use Safari and FB with no trouble. I don't know what I could have done though to cause this.
     
  6. thread starter macrumors member

    Joined:
    Mar 6, 2006
    #6
    Problem solved. It was AdBlock after all. Some weird problem with that plugin. I deleted it and it seems to have resolved the issues. Thanks again for all the great input.
     
  7. macrumors newbie

    Joined:
    Oct 2, 2008
    #7
    problem using facebook

    I have been having problems using FACEBOOK for the last three days. The submit buttons and many buttons for 'reply' etc don't work any more .. I can't leave messages or replies on walls or use the compose message feature because the addresses won't load .. the pages are not loading properly i guess.

    I am not much knowledgable about macs .. or pcs in general .. but when I found others had probs with mac and FB I thought maybe I could get some help too.

    What is ADBLOCK .. someone achieved some solution with that .. can someone help?

    It's making me crazy .. cause I spend so much time at FB and now I have to swicth on my stupid compaq laptop and get onto Firefox to send replies and write messages and on walls .. CRAZY!! I hate all other machines after Mac but it's ditching me BAADD!!
     
  8. macrumors regular

    Joined:
    Jul 28, 2008
    #8
    I'm not quite sure why this is happening either. I'm having the same problems and I don't have the Adblock plug-in. Anyone else have suggestions?
     
  9. macrumors newbie

    Joined:
    Dec 1, 2008
    #9
    (apologies for replying to an old post but it still shows on google)

    The problem seems to be Safari's Javascript implementation.

    Solution: Use Firefox and be happy or wait for Apple to fix it.
     
  10. macrumors newbie

    Joined:
    Dec 1, 2008
    #10
    Problems with facebook

    I am having problems with facebook both with safari and firefox. When I log in into facebook, inmediately after my home page is loaded firefox or safari close unexpectedly. This has happened also with "myspace". I don´t know if someone knows what the problem might be and how to fix it.

    I´ll appreciatte your help!!
    Thanks a lot...
     
  11. macrumors newbie

    Joined:
    Feb 1, 2009
    Location:
    Winnipeg, MB, Canada
    #11
    you don't need to reset everytime, Hit safari preferences and show cookies, remove all the facebook cookies and hit done. This is a temporary fix, but you don't need to reset everything. i'm unsure which cookie(s) actually is the cause of the problem.
     
  12. macrumors 6502a

    Joined:
    Aug 9, 2008
    #12
    No, the main issue is that you are not using firefox. Safari is much slower and has many more problems that firefox. I have been using firefox for a VERY long time, I couldn't be happier
     
  13. macrumors newbie

    Joined:
    Feb 8, 2009
    #13
    I am also using Safari on a Powerbook G4, 5 days ago problems started with facebook. I am still able to use facebook but each time when I want to invite friends to an event or group my Safari stops working. I also have this same problem using Firefox.

    When i look at the graphic of my CPU i notice that everytime u try to invite friends on facebook my CPU goes in red. So it seems that my computer has become to slow from one day to the next day.

    Its hard for mee to believe that a powerbook g4 isn't able to load a particular page on facebook ...

    I already deleted the cookies but still have the same problem.

    Hope someone can help me?

    Thanks in advance!
     
  14. macrumors newbie

    Joined:
    Feb 8, 2009
    #14
    I had similar problems - i just use the Camino browser now for facebook, also found that the chat functionality wasn't happening either.
     
  15. macrumors newbie

    Joined:
    Feb 8, 2009
    #15
    Ok thanks for the tip, will try with the Camino browser and see what happens!
     
  16. macrumors newbie

    Joined:
    Feb 27, 2009
    #16
    You might want to try Flock. It's a Mozilla-based browser that has special tools for Facebook. I've also used Firefox with success, and I'm running a PowerBook G4 too.

    I just downloaded Safari 4.0 beta and so far the new rendering engine seems to be handling things pretty well. You might want to give that a try, too.

    Camino is a fine browser but it has (documented ) screen rendering problems on 10.4.11. That should get fixed when they get to Camino 2.x.
     
  17. macrumors regular

    Joined:
    Aug 14, 2008
    #17
    i just found this on google. i've been having major issues with facebook lately, it won't ever load or work it's driving me crazy.

    actually since 10.5.7 i've been having a lot more issues with my mac, especially with safari and ichat
     
  18. macrumors newbie

    Joined:
    Apr 10, 2007
    #18
    Wow, this is such an old thread...but still the problem persists. For the first time in the last month or so I have been having problems with Safari not clicking on certain links in Facebook. Firefox has no problem with any of them. The following things don't work that worked just fine.

    - Inbox - Inbox doesn't load
    - Chat - List of friends online doesn't open up (but does display how many are online)
    - Accept/Reject friend invitation
    - Reply to wall post
    - Accept/Reject events

    ...all sorts of random things.

    Am running Safari 4.0.3. on MacOS Snow Leopard 10.6.1

    Anyone have a solution?
     
  19. macrumors 68020

    JML42691

    Joined:
    Oct 24, 2007
    #19
    I believe almost all of the issues are on facebook's side of the problem.
     
  20. macrumors member

    Joined:
    Sep 25, 2009
    #20
    Safari's Saft extension seemed to be causing me problems. After installing Saft, I'd get logged out of FB after a minute or so. Once I removed Saft, everything worked again.
     
  21. macrumors 6502a

    Joined:
    Sep 25, 2009
    #21
    I fixed a lot of the problems I had accessing Facebook by switching to Firefox.
     
  22. macrumors G3

    Kilamite

    Joined:
    Mar 20, 2007
    Location:
    Scotland
    #22
    I'm having problems - sometimes it'll just load the top bit of the new feed (the menu bar) and nothing else.

    Facebook chat hardly ever works either..
     
  23. macrumors regular

    Joined:
    Oct 21, 2009
    Location:
    UK
    #23
    Have exactly the same problem :-(
     
  24. macrumors G3

    Kilamite

    Joined:
    Mar 20, 2007
    Location:
    Scotland
    #24
    Well, the Safari 4.0.4 update released today has sorted all this, and Facebook appears to be working correctly now. Apple noted that there was some JavaScript enhancements/other fixes.
     
  25. macrumors newbie

    Joined:
    Dec 7, 2009
    #25
    Facebook Problems on Safari

    I am having a similar problem. Over the past few weeks I can only sometimes access facebook on my Mac. My husband uses a PC and doesn't seem to have a problem, so I'm guessing it must be a Mac problem. It will shut down in the middle of a session or just block me out completely. When I do get onto the site, I sometimes cannot post comments or send messages. It's driving me NUTS!! :mad:
     

Share This Page