Safari Favicons

Discussion in 'Mac Apps and Mac App Store' started by DrK, Jun 10, 2005.

  1. DrK macrumors newbie

    Joined:
    Jul 12, 2004
    Location:
    New York
    #1
    I just cleared out my icon cache and have noticed that favicons are not being displayed for certain sites.

    Macrumors is one of those that no longer gets a favicon.

    Does anyone know why certain sites are ok but others not. For instance the apple.com favicon is still displayed, but yahoo's is not.

    Curious!
     
  2. whocares macrumors 65816

    whocares

    Joined:
    Oct 9, 2002
    Location:
    :noitаɔo˩
    #2
    Yahoo, Apple and MR all have favicons in my Safari :cool:
     
  3. camomac macrumors 6502a

    camomac

    Joined:
    Jan 26, 2005
    Location:
    Left Coast
    #3
    what are favorcons?
    is that the little icons in the URL address in the browser?
     
  4. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #4
    Does this mean you emptied the cache or that you quit Safari, navigated to ~/Library/Safari/Icons/ and threw all the contents of that into trash and emptied trash and restarted Safari...?
     
  5. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #5
    I too am unable to get favicons for some websites after clean 10.4 installs (on three different computers). Also have tried dumping cache after quitting Safari, etc, etc. Ultimately, I have given up on the icons.
     
  6. DrK thread starter macrumors newbie

    Joined:
    Jul 12, 2004
    Location:
    New York
    #6
    First to answer camomac, yes ... these are the little icons that appear in the bookmark lists and the address bar.

    And to answer Mitthrawnuruodo, this was exactly what I did ... I went the library deleted the icons, emptied the trash and restarted safari. I did this as I was testing some of my own favicons.

    The favicon for yahoo.com was appearing before I did this, but it no longer appears :(
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    It looks like their favicon has disappeared alltogether, I didn't get it at all and on top of that the icon seems to be invisible: http://www.yahoo.com/favicon.ico
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    This behavior is normal if the site changed its favicon - this appears to be what has happened. Nothing's gone wrong.
     
  9. beg_ne macrumors 6502

    Joined:
    Jul 3, 2003
    #9
    I've noticed lots of sites doing this since doing a clean install of 10.4. Perhaps Safari now only accepts certain types of favicons?
     
  10. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #10
    Yep... invisible in Safari but shows up in Firefox... definitively a Safari bug...
     
  11. DrK thread starter macrumors newbie

    Joined:
    Jul 12, 2004
    Location:
    New York
    #11

Share This Page