Safari History Problem with Google Searches

Discussion in 'Mac Applications and Mac App Store' started by iEdd, Feb 8, 2012.

  1. macrumors 68000

    iEdd

    Joined:
    Aug 8, 2005
    Location:
    Australia
    #1
    Has anyone else noticed that if you open Google search results in a new tab/window, the results in your Safari history are displayed as:
    http://www.google.com.au/url?sa=t&r...ejD0HTUdvf-7m4hYg&sig2=oCpRGW-s5NWPwu6m4yfu7w
    instead of
    www.wikipedia.org
    ???

    Others also seem to have this issue, some dating back 1-2 years.

    One suggestion I read said to turn off Google instant, but that hasn't fixed the problem.

    Has anyone fixed this? Or is it time to just admit to ourselves that Safari has been ruined and move on to Chrome already?

    I'm using Safari Version 5.1.3 (7534.53.10) in Lion, but had this problem with 5.1 in Snow Leopard too.

    Appreciate any help.
    Thanks.
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    This is because Google adds all the extra "junk" to track information about which search results generate clicks. If you go to the actual page, that information is stripped off, but it's annoying if you want to copy the link directly from the search results page.
     
  3. thread starter macrumors 68000

    iEdd

    Joined:
    Aug 8, 2005
    Location:
    Australia
    #3
    Yes, I understand that, but other browsers, like Firefox and Chrome will resolve the redirect and log the history with the final address and appropriate title.

    In fact, Safari does this correctly if you open the Google search result in the current tab - which is of no use when I frequently cmd+shift then click out a bunch of results into new tabs.
     
  4. thread starter macrumors 68000

    iEdd

    Joined:
    Aug 8, 2005
    Location:
    Australia
    #4
    Solved

    For anyone with this same problem, there is a solution out there:
    http://ask.metafilter.com/201154/Google-results-arent-recorded-inSafari-history
    (You can download a safari extension for .com and .co.uk google there.)

    This extension previously didn't work for me, as it isn't setup for google.au. To get it to work, I pasted those 2 lines of javascript:
    Code:
    var links = document.getElementsByClassName('l');
    for(l in links) if (links[l].onmousedown) links[l].removeAttribute("onmousedown");
    into a file I called main.js, then setup a Safari extension as in the screenshot shown below. Anyone wishing to make their own for .au (or any other domains can now do so using these settings).

    Thankyou nowonmai and tylerkaraszewski of metafilter!
     

    Attached Files:

  5. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    And thank you for finding and posting this! This has been a pain in the browser for far too long!
     
  6. macrumors 603

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #6
    YES!

    Thank you so much for that plug in!

    This page is the final one that will have that (no title) entry in my history :)
     
  7. macrumors member

    Joined:
    Apr 2, 2007
    #7
    Are you having success with this extension with Mountain Lion's Safari (6.0.2)? I wrote about this solution a while back, but since upgrading to Mountain Lion the scrambled URLs are back. I've removed/reinstalled the extension to no avail.

    Any ideas?
     
  8. thread starter macrumors 68000

    iEdd

    Joined:
    Aug 8, 2005
    Location:
    Australia
    #8
    Yeah, same here. Frustratingly just starting to accept that Safari is a broken browser.
     
  9. macrumors newbie

    Joined:
    Apr 27, 2013
    #9
    Safari 6 Plugin

    There's a different plugin called "Hisory Washer" that works in Safari 6 and fixes the issue for all Google searches performed after installing it. Works for me in Safari 6.0.3.

    You can download it for free at www.leanbyte.com/historywasher.
     
  10. macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #10
    Links no longer have the l class on the results page.

    If you change the first line (in the script posted):
    Code:
    var links = document.getElementsByClassName('l');
    to this:
    Code:
    var links = document.querySelectorAll("h3.r a");
    It should work again.
     
  11. thread starter macrumors 68000

    iEdd

    Joined:
    Aug 8, 2005
    Location:
    Australia
    #11
    Thanks for the tip, elppa.

    Unfortunately, it only seems to fix it when you:
    • Go to www.google.com (or .com.au)
    • Search
    • Click a result

    If I type the search into the safari search/address bar, then click a result, I still get the garbled history entries. Any ideas?
     
  12. macrumors regular

    Joined:
    Dec 26, 2008
    Location:
    Lanka Ravi Shanka
    #12

Share This Page