safari: how to set default program for magnet link

Discussion in 'Mac Apps and Mac App Store' started by Tymmz, Dec 26, 2009.

  1. macrumors 65816

    Tymmz

    Joined:
    Jan 6, 2005
    #1
    hi everyone.

    how do i tell safari to open transmission and not azureus when clicking on a magnet link.

    thank you very much!

    tymmz
     
  2. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Finder > select .torrent file > Get Info > Open With > change to Transmission > Change All
     
  3. thread starter macrumors 65816

    Tymmz

    Joined:
    Jan 6, 2005
    #3
    cheers, but magnet links are not associated with files.
     
  4. macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
    #4
    Edit: the steps are different when going from Azureus to Transmission than if you're just installing Transmission:

    Bring up a terminal and run this command:
    Code:
    plutil -convert xml1 ~/Library/Preferences/com.apple.launchServices.plist
    then edit com.apple.launchServices.plist with any text editor. Search for the word magnet. You should find a block that looks like this:
    Code:
    <dict>
            <key>LSHandlerRoleAll</key>
            <string>[b]org.gudy.azureus2[/b]</string>
            <key>LSHandlerURLScheme</key>
            <string>magnet</string>
    </dict>
    Change it to
    Code:
    <dict>
            <key>LSHandlerRoleAll</key>
            <string>[b]org.m0k.transmission[/b]</string>
            <key>LSHandlerURLScheme</key>
            <string>magnet</string>
    </dict>
    Then type
    Code:
    plutil -convert binary1 ~/Library/Preferences/com.apple.launchServices.plist
    and reboot.
     
  5. macrumors newbie

    Joined:
    Jan 20, 2010
    #5
    Or more easy download MoreInternet Pref Pane
    http://www.monkeyfood.com/software/moreinternet/

    and make a new protocol "magnet" and choose Transmission as program to open with.

    The newest beta of Transmission does support Magnet links :)
     
  6. macrumors newbie

    Joined:
    Feb 21, 2011
    #6
    here's the answer!

    I searched all around for this answer and then thought to go to preferences within transmission and sure enough there was a button that set transmission as the default for mirror links. Easy as that!
     
  7. macrumors regular

    Joined:
    Jul 26, 2010
    #7
    I'm on version 4.0.2 and I can't seem to find that option. Could you explain it in more detail?

    thanks
     
  8. macrumors newbie

    Joined:
    Feb 4, 2009
    #8
    Preferences->General-> click "Set Default Application" next to "Accept Magnet Links"

    I had no problem with this until, randomly (and these are the only recent computer use changes), I updated my phone to iOS 6 and backed up my computer with TimeMachine. Then Safari would not load the magnet links anymore. Clicked this and no problems.

    Transmission 2.71
     
  9. macrumors newbie

    Joined:
    May 17, 2004
    #9
    Use RCDefaultApp to set file or protocol associations. It works like a charm.

    ------------
    RCDefaultApp is a Mac OS X 10.2 or later preference pane that allows a user to set the default application used for various URL schemes, file extensions, file types, MIME types, and Uniform Type Identifiers
     
  10. thread starter macrumors 65816

    Tymmz

    Joined:
    Jan 6, 2005
    #10
    cheers, but that was three years ago...:)
     
  11. macrumors 6502

    Joined:
    Dec 21, 2005
    #11
    Magnet links were opening in uTorrent instead of Vuze, and I could not figure out how to change this. But the RCDefaultApp solved the problem! I'm using Safari on 10.8.4.
     

Share This Page