Safari is Worrying Me

Discussion in 'Macintosh Computers' started by dabirdwell, Jan 15, 2003.

  1. macrumors 6502

    Joined:
    Sep 26, 2002
    Location:
    Oklahoma
    #1
    OK,

    So two days ago I notice Safari has stopped working, alright, I uninstall it and reinstall it, and it installs but when I try to launch the application it immediately says "Safari has quit for an unknown reason"

    I did another uninstall and reinstall and now when it tries to mount the disk image for the install it gets stuck on a box that says "waiting for disk copy helper"

    Anyone have any idea? I have tried everything I know to try.


    I think someone else said this happened to them when they changed the startup page for the browser. I also did this...

    Thanks
     
  2. macrumors regular

    Joined:
    Jan 3, 2003
    #2
    Which version of OSX are you on? On the Safari homepage it says the following: "The Safari Public Beta works on all Macintosh computers running Mac OS X v10.2 or later, but runs best when using Mac OS X v10.2.3"

    :p
     
  3. macrumors 603

    rainman::|:|

    Joined:
    Feb 2, 2002
    Location:
    iowa
    #3
    That disk copy isn't working right suggests a larger problem; whether it's caused by safari is questionable. It's possible safari, during whatever problem it had, caused something to happen to the rest of the system, it's also possible something else happened and caused safari and disk copy to stop working correctly. Can you mount other disk images? the content of the disk image *shouldn't* affect disk copy's performance.

    As chuck asked, what system are you running?

    pnw
     
  4. thread starter macrumors 6502

    Joined:
    Sep 26, 2002
    Location:
    Oklahoma
    #4
    I am running 10.2.3 currently. I think I just replied to the thread about your wifes iBook.

    And I can mount other disk images, I installed Stuffit again, it was having problems too.
     
  5. macrumors regular

    Joined:
    Aug 31, 2002
    #5
    Re: Safari is Worrying Me

    That bit at least sounds like a corrupted preferences file.

    Go to Home > Library > Preferences and delete com.apple.Safari.plist I think it's called. As for the newer problems I don't have a clue :p
     
  6. macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #6
    Repair your disk permissions. Most likely Safari isn't able to access a necessary file because of corrupted permissions. Could also be the cause of your Disk Image problem.
     
  7. macrumors regular

    Joined:
    Nov 15, 2002
    #7
    More safari problems?

    I've had to ban its use on our network as it completely fouls up our backup systems.
     
  8. macrumors 6502a

    Dunepilot

    Joined:
    Feb 25, 2002
    Location:
    UK
    #8
    How do you repair disk permissions?

    Something strange happened to me the other day when I was trying to duplicate a standard audio CD (for backup purposes ;) ) and disk copy was having none of it. When I tried to do it through iTunes it was all okay apart from the last track which it just couldn't rip from the CD. Very odd.
     
  9. macrumors regular

    Joined:
    Nov 15, 2002
    #9
    load Disk Utilitiy (in the Utilities folder in Applications)

    Select the drive/partition OSX is installed in

    Select First Aid tab

    Click on 'Repair Disk Permissions'
     
  10. macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #10

    Read this guide on repairing disk permissions that I wrote yesterday.

    http://forums.macrumors.com/showthread.php?s=&threadid=17722
     
  11. macrumors 6502a

    ShaolinMiddleFinger

    Joined:
    Oct 12, 2001
    #11
    Re: Re: Safari is Worrying Me

    This definately worked for me. Thanks Telomar!
     

Share This Page