Safari Keyboard shortcuts not working

Discussion in 'Mac OS X Lion (10.7)' started by insomniac321123, May 3, 2011.

  1. macrumors 6502

    Joined:
    Jan 23, 2006
    Location:
    Milwaukee, WI
    #1
    Is anyone else having a problem with the keyboard shortcuts in Safari not working after a short period time of using the browser? For some reason my keyboard shortcuts stop working after a while. Nothing I don't have any problems with anything else, just the keyboard shortcuts. A restart of the browser fixes it. Is anyone else seeing this?
     
  2. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #2
    Which shortcuts? Copy, Paste?
    No problems here with most common shortcuts.
     
  3. thread starter macrumors 6502

    Joined:
    Jan 23, 2006
    Location:
    Milwaukee, WI
    #3
    I think it may have been a byproduct of a 1password update. It was updated again and the problem seems to have gone away.
     
  4. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    So your 1Password shortcuts did not work?
     
  5. thread starter macrumors 6502

    Joined:
    Jan 23, 2006
    Location:
    Milwaukee, WI
    #5
    No, all of the shortcuts didn't work. Copy, paste, etc. It was very frustrating, but I haven't seen the problem since the most recent beta update of 1password. Thats my best guess about the problem.
     
  6. macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    Weird. I have to admit I am glad to see 1Password finally working pretty well for Safari.
     
  7. thread starter macrumors 6502

    Joined:
    Jan 23, 2006
    Location:
    Milwaukee, WI
    #7
    Now if I could get a working evernote extension and speed download extension, I will be set in safari.
     
  8. macrumors newbie

    Joined:
    Oct 21, 2008
    #8
    Same problem...

    I'm having the exact same problem with Safari -- all command-key enabled shortcuts stop functioning after a short time. Only restarting Safari solves the problem. I do not use 1Password.
     
  9. moogle301, Nov 3, 2012
    Last edited: Nov 3, 2012

    macrumors member

    moogle301

    Joined:
    Nov 29, 2009
    #9
    I do not use it either and have this problem but only for the 'Google Search...' jump to search box keyboard shortcut (which I have set to cmdK). It was working fine before and I don't think I've changed anything recently.

    https://discussions.apple.com/thread/4480345

    and restarting browser and mac does nothing. neither does disabling extensions. started a few days ago

    oh, and i don't use Lion, but Snow Leopard
     

Share This Page