Safari & Myspace -- stopping auto downloads

Discussion in 'Mac Apps and Mac App Store' started by grubber, Aug 21, 2005.

  1. grubber macrumors newbie

    Mar 7, 2005
    While browsing around MySpace, some users have (annoyingly, heh) included music & videos in their profile pages. This causes Safari to automatically download *.wmv files and launch iTunes (or stop currently playing songs) for *.m3u files. Is there anyway to at least make Safari prompt me before it downloads these files? I can't figure out where to go to turn off the way it handles certain extensions.
  2. iMatt mini macrumors 6502

    Mar 1, 2005
    Central New Jersey
    I could easily tell you how if you had Firefox. I don't think there is a way with Safari.
  3. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I think you can only turn off launching of all "safe" filetypes, through Safari preferences.

    But there's something strange about this:

    - MP3s, etc, should play inline, in the window, with Quicktime. They shouldn't be launching iTunes, unless you set your system up that way.

    - WMV should be playing inline with Windows Media Player, unless you're using something else.

    I've never had automatic downloads from MySpace in Safari, and I have the setting to auto-play safe files checked.
  4. grubber thread starter macrumors newbie

    Mar 7, 2005
    Well, the WMV actually launches VLC (a third-party avi viewer -- got it so i can watch full screen). So, maybe the extension association got messed up? I'm new to the Mac and I know how to fix it in Linux & Windows, but not the Mac-way.
  5. GimmeSlack12 macrumors 603


    Apr 29, 2005
    San Francisco
    My solution to this problem (with FireFox & Safari) just delete the WMP internet plug-in (user/library/internet plug-ins). That solved it for me. Cause I can't stand the hang ups and force quits of my browser.

Share This Page