Safari not blocking popups?

Discussion in 'iMac' started by 2012Tony2012, Feb 7, 2013.

  1. macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #1
    Safari refuses to block popup windows that open up BEHIND Safari.

    How on Earth can I stop those annoying popup windows for good?
     
  2. macrumors 6502

    Joined:
    Mar 29, 2012
    #2
  3. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #3
  4. macrumors 6502

    Joined:
    Mar 29, 2012
    #4
  5. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #5
    I have already installed Adblockplus, but those popups still open up behind my browser.

    Any other suggestions?

    And by the way I have no idea how to install Fanboy on Safari? And that new link you gave me still points back to the old webpage with the BROKEN LINKS!
     
  6. macrumors newbie

    Joined:
    Sep 23, 2009
    #6
  7. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #7
    For the record, why doesn't addblockplus stop thoose annoying popus from opening up? I see a quick flash and then windows open up behind Safari!

    SURELY there is a way to stop that????:mad:
     
  8. macrumors 6502

    Joined:
    Mar 29, 2012
    #8
    1. Make sure block pop-ups is checked in security of Safari preferences.
    2. Download Adblock from Safari extensions gallery.
    3. Go to Adblock options, Filter Lists, then click HERE.
    4. Scroll down to Fanboy's Annoyances list and hit Subscribe.
    5. Click Homepage on Fanboy's Annoyances list and subscribe Annoyances again.
     

    Attached Files:

  9. macrumors 6502

    Joined:
    Mar 29, 2012
    #9
    This is how my filters look like.
     

    Attached Files:

  10. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #10
    When I follow your steps, I do NOT see Fanboy's Annoyances list anywhere!

    The last thing I see on my list is "EasyPrivacy (privacy protection)"

    How did you get fanboys to appear?
     
  11. macrumors 6502

    Joined:
    Mar 29, 2012
    #11
    Click HERE on the first line.

    Don't subscribe to more than you need -- every one slows you down a tiny bit! Credits and more lists can be found here.
     

    Attached Files:

  12. 2012Tony2012, Feb 7, 2013
    Last edited: Feb 7, 2013

    thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #12
    Ok, but how did you get the fanboys "addon"? I dont see that one anywhere.
     
  13. macrumors 6502

    Joined:
    Mar 29, 2012
    #13
    When you click HERE, this page appears.
     

    Attached Files:

  14. macrumors 6502

    Joined:
    Mar 29, 2012
    #14
    Scroll down
     

    Attached Files:

  15. macrumors 6502

    Joined:
    Mar 29, 2012
    #15
    On adblock filter lists page did you click this

    click HERE.
     

    Attached Files:

  16. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #16
    Did all as you suggested and popups still popup :mad:
     
  17. macrumors 6502

    Joined:
    Mar 29, 2012
    #17
    Try changing your DNS settings to Open DNS.
    208.67.222.222 for primary.
    208.67.220.220 for secondary.
     
  18. macrumors 6502

    Joined:
    Mar 29, 2012
    #18
    How to do it

    Go to System Preferences > Network > Click “Advanced”
    Click the “DNS” tab
    In the DNS Servers and Search Domains boxes, select each item and remove by pressing the “-” (minus) button
    In the DNS Servers, click “+” and then paste or type in 208.67.222.222, 208.67.220.220, 208.67.222.220 and 208.67.220.222 one at a time.
    In the Search Domain box, click the “+” and then paste (or type) guide.opendns.com
    Reset safari.
     
  19. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #19
    That didn't stop the popups either.

    Any other suggestions?
     
  20. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #20
    What site are you getting these popups on?
     
  21. FreemanW, Feb 8, 2013
    Last edited by a moderator: Feb 8, 2013

    macrumors 6502

    Joined:
    Sep 10, 2012
    Location:
    The Real Northern California
    #21
    You bet!

    Stop going to that page. The domain owner sells ad space.
     
  22. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #22
    A lot of random websites which have videos, many of them do it. When I click on the video to play the video, I see a quick flash and a window opens up in the background. No matter what I have tried to do, they keep opening!

    Is there a way to STOP this happening?
     
  23. macrumors 6502

    Joined:
    Mar 29, 2012
    #23
    Give javascript blocker and ghostery a try. they both are under security in safari extensions gallery. Can't think of anything else.
     
  24. thread starter macrumors 6502a

    2012Tony2012

    Joined:
    Dec 2, 2012
    #24
    Installed both javascript blocker and ghostery, but popups still popup :mad:

    Anyone else have a solution? Or is it impossible to stop 100% of all popus on Safari?

    What browser can stop 100% of all popus?:eek:
     

Share This Page