Safari Problems!

Discussion in 'Mac Apps and Mac App Store' started by topspin98, Feb 20, 2005.

  1. topspin98 macrumors member

    Joined:
    Dec 30, 2004
    #1
    When ever I open my Safari, it says it fail to connect tothe homepage and any other site. And I have no idea how to fix it. My Wireless showed that it had high connection, but who knows. I deleted Internet Explorer in the past so i can delete Safari then rreinstall it.

    jake
     
  2. YS2003 macrumors 68020

    YS2003

    Joined:
    Dec 24, 2004
    Location:
    Finally I have arrived.....
    #2
    update to 10.3.8

    Did you have a 10.3.7 update through OS X's updater? I had a similar problem with my Ti and Al PB after that update. I did a erase and install on both machines and used the combo update. No more problems with Safari. I heard you can run a combo update without erase and install to fix that type of problem.
     
  3. jim. macrumors 6502

    Joined:
    Dec 22, 2004
    Location:
    C-ville, VA
    #3
    This is a common complaint with Safari, or at least it used to be. Supposedly recent updates from Apple addressed this bug. Are you fully updated? Have you tried using another browser like Camino or Firefox?

    I am assuming that Safari works as expected after the startup error?

    Jim
     
  4. fjs08 macrumors 65816

    Joined:
    Jun 25, 2003
    #4
    I had the problem a bit with 10.3.7, but Safari has become dysfunctional since my update with 10.3.8.

    I'm using FireFox now and am ecstatic with it. I just won't go back until something is done. I like Safari, but I just can't use it. And one of the reasons I left the PC world was the need for all that uninstall, reinstall stuff.

    Nothing personal to the person who did the combo update, but that isn't why I came back to Mac.

    I use Camino too, but find it a bit too unpolished. I really like FireFox.

    Frank
     
  5. YS2003 macrumors 68020

    YS2003

    Joined:
    Dec 24, 2004
    Location:
    Finally I have arrived.....
    #5
    not updating to 10.3.8

    After erase & install OS X (due to 10.3.7 update-cuased internet connection malfunction), I have not updated to 10.3.8 (after doing the combo update to 10.3.7). According to the some posts on the forum, 10.3.8 update may be a hit or miss in terms of the system stability. I opted not to do the 10.3.8 update as the features of that update are not needed in my computing needs.
     

Share This Page