Safari question/annoyance....

Discussion in 'Mac Apps and Mac App Store' started by Delta-9, May 13, 2003.

  1. Delta-9 macrumors newbie

    Joined:
    Apr 9, 2003
    Location:
    PA
    #1
    When I accidently mistype something into the URL field on safari, like the following:

    forum.macrumors.cmo (I know this is a fictious URL but its easier for illustration purposes)

    After I press enter, I get an error box "Server Not Found" and then safari tries to fix this by adding an extra "www." to the front of my URL and I end up with this in the URL field:

    www.forum.macrumors.cmo

    Obviously that doesn't work either, except now I have to either delete the entire thing and start all over again, or fix the .cmo to .com *AND* delete the extra "www." that safari added there for me.

    My question: how the hell do I disable this?


    Thanks.

    Jon
     
  2. crazytom macrumors 6502a

    crazytom

    Joined:
    Jul 23, 2002
    Location:
    IL
    #2
    AFAIK, you can't disable this. Safari won't accept the 'autofill' of the URL until you hit return, otherwise, you just keep typing (which you'd have to do anyway if it was disabled) or better yet, bookmark the page the one time you do type it in correctly. The autofill doesn't really get in the way of anything, if it does (that is, if it fills in more than you need), press the space bar then return.
     
  3. rainman::|:| macrumors 603

    rainman::|:|

    Joined:
    Feb 2, 2002
    Location:
    iowa
    #3
    there are some major issues with both the location and search bars, not just your annoyance but a lot of 'cursor won't stay' &etc. i am hoping apple spends some time finishing the two bars before the final version is released...

    pnw
     

Share This Page