Safari - reinstall?

Discussion in 'Mac Apps and Mac App Store' started by Ines, Sep 25, 2005.

  1. Ines macrumors member

    Joined:
    Aug 16, 2004
    Location:
    London
    #1
    Hi

    I am on Mac OSX 10.4.2 and have Safari 2.0.1 it constantly crashes when I close a window opened from a webpage - either by the red x or is I click on the "close window" link.

    I am now getting lots of Java errors.

    Can someone let me know if its possible for me to just reinstall Safari? Or have I go to re-install 10.4 ... and if so I just do an upgrade again dont I (so I dont lose anything)?

    thanks as always
    Ines
     
  2. Daveway macrumors 68040

    Daveway

    Joined:
    Jul 10, 2004
    Location:
    New Orleans / Lafayette, La
  3. drumpat01 macrumors 6502

    drumpat01

    Joined:
    Jul 31, 2004
    Location:
    Denton, TX
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Try resetting Safari first from the Safari menu. Then use Spotlight to find a file with Safari and PLIST in the name (com.apple.safari.plist). This is the preference file and it can safely be deleted (drag to trash can) assuming Safari is closed at the time. Next time Safari opens, it'll revert back to the original preference settings, recreating this file. :)
     
  5. drumpat01 macrumors 6502

    drumpat01

    Joined:
    Jul 31, 2004
    Location:
    Denton, TX
    #5
    ok i tried to just drag and drop everything with name safari into the trash, delete, then restarted, downloaded Safari 2.0.1 from apple's web page and when i try to install it gives me this error:

    You can not install Safari 1.2 on this volume. this system cannot use this software

    any ideas?
     
  6. joecool85 macrumors 65816

    joecool85

    Joined:
    Mar 9, 2005
    Location:
    Maine
    #6
    Your image isn't showing up for me...if you can get it up that'd be great. I'd love to help you with your problem, I use Safari everyday and its my fav. browser.
     
  7. drumpat01 macrumors 6502

    drumpat01

    Joined:
    Jul 31, 2004
    Location:
    Denton, TX
    #7
    ok, figured out i was trying to download an old verion of safari so thats why it wasn't working, but....

    now i downloaded 2.0.1 and its saying I have to have OS 10.4.2!!! So now what do I do?
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    What I would recommend is trying to download and run an OS combo updater, either for 10.4.2 or 10.4.3.... Is there a specific reason you cannot go to 10.4.3 right now? Download the actual full size combo updater from the web to be on the safe side...I would think that it will overwrite your Safari anyway -- both of these releases came with new versions of Safari, IIRC, and in particular, 10.4.3 features 2.0.2.
     
  9. spinner macrumors regular

    Joined:
    Jan 16, 2002
    Location:
    South Dakota
    #9
    ines,
    i have run into this same problem on 10.4.3 and safari 2.0.2. I play the mmorpg runescape alot, its an embedded java app and since beginning to play i have seen safari go from exceptionally stable to a crash prone piece of crap. Safari usually only uses about 10-20% of available proc power but now when i play the game it pegs out at 85-90% basically bringing the whole system to its knees. I have tried repairing permissions, I have ran techtool and nothing. So if anyone knows how to fix this PLEASE help.
     

Share This Page