Safari search oddity

Discussion in 'Mac Apps and Mac App Store' started by cartel1, Dec 22, 2006.

  1. cartel1 macrumors newbie

    Joined:
    Sep 16, 2006
    Location:
    Nottinghamshire, UK
    #1
    The Google search box on Safari seems to have defaulted to Russian! All search results are in English but the links and any other text on the search page are in the Russian script.
    It's also Russian if I type www.google.com in the location box, all is as it should be when I use Firefox, all in English.

    Has anyone else had this happen, how do I get back to English? There is nothing in the prefs that I can see that will change it.

    Terry
     
  2. mnkeybsness macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Location:
    Moneyapolis, Minnesota
    #2
    try going to the google preferences page and setting your language there.

    is your computer's default language in russian? that could easily make google think you want russian.
     
  3. cartel1 thread starter macrumors newbie

    Joined:
    Sep 16, 2006
    Location:
    Nottinghamshire, UK
    #3
    The default language for the machine is English, however I used the link above and guess what the page was all in russian or some other cyrillic language, so I had to get the same page up in Firefox which was in english and try to negotiate my way through the prefs on the Safari-Google.com page.

    I even used the translator widget in dashboard to find the Russian spelling of 'English' and tried to find a match in the Safari-Google.com page, no exact match but some similar pattern match got me there in the end. Weird stuff, I wonder how that happened.

    Thanks for the link :)
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Next time it happens, it might be quicker to delete your Google cookie in Safari's Preferences. :)
     

Share This Page