Safari Won't Open

Discussion in 'Mac Apps and Mac App Store' started by jaredbbauer, Feb 3, 2004.

  1. jaredbbauer macrumors member

    Joined:
    Oct 24, 2001
    Location:
    Salt Lake City
    #1
    I have been having problems with safari for a couple of months now. I have deleted the caches reinstalled, upgraded to the new one, and everything! However, every time it goes to open it starts and then unexpectadly quits! all of my other browsers work fine. I am running everything over airport and it is all configured correctly. Not sure what else to do! Please someone help!!!
     
  2. virividox macrumors 601

    virividox

    Joined:
    Aug 19, 2003
    Location:
    Manila - Nottingham - Philadelphia - Santa Barbar
    #2
    try running a permissions repair, often when permissions are corrupted it causes apps to shut down unxepctedly. it should be under 'disk utility' in your utilities folder, do this before and after any installations
     
  3. rdowns Suspended

    rdowns

    Joined:
    Jul 11, 2003
    #3
    Have you deleted its preferences (plist) file?

    If I were you, I'd search for Safari in a finder window and delete all the files and then do a re-install. Recommend you save your bookmarks file though.
     
  4. jaredbbauer thread starter macrumors member

    Joined:
    Oct 24, 2001
    Location:
    Salt Lake City
    #4
    DID ALL OF THAT

    Thanks for the input, I did this, I searched in the finder... deleted everything to do with safari, repaired permissions, installed safari, restarted, repaired permissions and it still won't open!!!!
     
  5. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #5
    what OS are you running and have you tried Safari v1.2 (just out)?
     
  6. jaredbbauer thread starter macrumors member

    Joined:
    Oct 24, 2001
    Location:
    Salt Lake City
    #6
    I am running panther and have been trying to install version 1.2
     
  7. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #7
    how exactly does the install fail?
     
  8. jaredbbauer thread starter macrumors member

    Joined:
    Oct 24, 2001
    Location:
    Salt Lake City
    #8
    It does not fail to install... it installs completely it just won't open. It bounces, opens up and then fails to load the website and unexpectadly quits with that stupid little report problem to apple thing.
     
  9. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #9
    ugh.

    i'm leaning towards a corrupted config-type file that you missed in your safari cleanup.

    i'm finding safari files here:

    ~/Library/Safari
    ~/Library/Caches/Safari
    ~/Library/Preferences/com.apple.Safari.plist


    oh, that list was shorter than i'd thought. now i wonder if i'm missing anything. does this list match what you found?

    you may also want to (at least temporarily) move the files from:

    /Library/Internet Plug-Ins
    ~/Library/Internet Plug-Ins
     

Share This Page