Safari's "swipe to go back" feature - annoying.

Discussion in 'OS X Mountain Lion (10.8)' started by Tander, Jun 20, 2013.

  1. macrumors 6502a


    Oct 21, 2011
    Johannesburg, South Africa
    Hi all,

    So I have been "dealing" with this annoying feature of Safari for a while now. But I have had enough. So I am wondering if it is just me that's suffering?

    When ever I swipe the mouse / track pad to go back to the last web page I am presented with a white blank page for a few seconds while Safari decides to reload that page. Yes, it's "small" and seems trivial. However it's frustrating.

    I went over to the latest version of Chrome and while they implement this feature too - pages I go back to don't reload.

    Is there a way to stop Safari from reloading the page?
  2. macrumors 6502a

    Nov 4, 2012
    Sometimes when you swipe the page will load instantly and other times it does take a bit and then you see the white screen

    Unfortunately there is no way to stop it from reloading the page as far as I know, only solution would be to switch to Chrome or Firefox if you still want to swipe back and forth without the unnecessary loading
  3. macrumors 6502a

    Sep 16, 2011
    Yes this bothers me too, especially when my website uses horizontal scrolling. I always accidentally go back to the previous page, and wait for it to reload, and go back to where I was.

    I believe there's a way around it by sacrificing another swiping feature... I'm not on ML or my MB right now, but it's in the Trackpad options under system preferences. You can turn off or on 3 finger to swipe? or make it 2 fingers? I remember trying it and it seemed to have stopped the reloading.. I will try again when I get home.
  4. macrumors member

    Jun 9, 2013
    I had this problem when I first got my macbook (last week). Although it was a pretty cool feature the refreshing of the previous page was just annoying. I ended up disabling it.

    Go to System Prefences -> Trackpad -> More Gestures -> Uncheck "Swipe between pages"
  5. macrumors 6502a

    Sep 16, 2011
    Yeah that's the option. You can change it to Swipe with three fingers, might still be useful when you want use it. But it'll also take away three finger drag if you have that on.
  6. crjackson2134, Jun 27, 2013
    Last edited: Jun 27, 2013

    macrumors 68020


    Mar 6, 2013
    Charlotte, NC
  7. coldjeanzzz, Jun 27, 2013
    Last edited: Jun 27, 2013

    macrumors 6502a

    Nov 4, 2012
  8. crjackson2134, Jun 27, 2013
    Last edited: Jun 27, 2013

    macrumors 68020


    Mar 6, 2013
    Charlotte, NC
    Sorry, I know I found a way to do this a while back and it worked. I couldn't remember so I googled it. It's possible that I changed it with a utility (either ONYX or COCKTAIL) those are the only 2 I've ever had installed. It's quite possible that I used one of these utilities.


    Have a look at THIS utility.

    If neither of these apps help, I don't know. I've been looking for quite some time since the original post, and it seem near impossible with the latest update. You can turn off the swipe or change it to 3 fingers and some have said that works. I haven't tested it and I really don't want to give up the swipe feature.
  9. macrumors newbie

    Sep 6, 2013
    I just started getting this problem a few days ago. I swipe back and the page stays white and never loads at all. If I swipe back 5 or 6 times sometimes it reloads. What could have triggered this?
  10. macrumors newbie

    Jun 8, 2013
    Just got my first Mac, and this is such as sweet feature (swiping to go back on web pages), but YES THIS IS SO ANNOYING!!!

    Why can't it just not reload, and you can press reload if you want to reload it yourself?

    Moreover, I like to browse through auction sites and I would automatically try to scroll down, but then it stutter because as you know it's RE-LOADING AUTOMATICALLY!

    Apple - can't you guys please come up with a fix for this? It's such an annoying glitch.

    EVERYTHING about this beautiful Mac is perfect, except this reloading issue.
  11. macrumors newbie

    Apr 5, 2012
    Scott AFB, IL
    I know it's a little late to reply, but I found that disabling AdBlock solved the refresh issue. Doesn't do it anymore.
  12. macrumors regular

    Nov 28, 2013
    If anyone's interested, this is MUCH better in Safari 8 (Yosemite). It still refreshes but the screen doesn't jump as it repositions and you can scroll and click another link without waiting.

    The worst example was on this very forum, and now it's much better.
  13. macrumors 6502

    Aug 1, 2012
    Thanks for the update Adrian!
    Looking forward to trying Safari under Yosemite.
    For me also the biggest issue was with MacRumors Front Page and forum.

    Been suffering with page reloads and dead white pages for the last two years so hopefully we'll see some improvement and less frustration.
    I love the swipe/gesture features and for the most part I prefer Safari. I do have swipe activated in Firefox and it is super fast and no weird issues but it lacks some of the swipe gesture options. So here's hoping Yosemite will improve the user experience. :)
  14. iLLUMI, Oct 1, 2014
    Last edited: Oct 1, 2014

    macrumors 6502

    Aug 1, 2012
    Yep, that's what I found too.
    I have Safari 6.0 running under OSX 10.8.
    The option to tick is Use Single-process Windows.
    Initially it seemed to work. When that option is selected you can still swipe, but when you close and relaunch Safari swiping is no longer available. One particular website (Beatport) just looked awful as images weren't properly loaded up or they were in odd places.
    When I checked the Debug menu the Use Single.. option was no longer ticked. Huh???
    To change it back to normal I re-ticked the option then un-ticked it then relaunched Safari.

    Any other suggestions from anyone?

    Switching off swiping doesn't really do anything. You can simply leave swiping active and just use the back button.
  15. macrumors 601

    Jun 29, 2010
    Soooo annoying it's still like this. It's why i use chrome but would rather use Safari.

Share This Page