1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Same book keeps crashing in iBooks

Discussion in 'iPad Apps' started by -tWv-, Jul 14, 2011.

  1. macrumors 68000

    -tWv-

    #1
    I downloaded The Lord of the Rings Complete Trilogy on my ipad, and it has been working fine and I have read around 400 pages of it up until today. Now, whenever I attempt to open the book on either my iphone or ipad, the book crashes immediately and I can't even flip the page. I have 3 other books in iBooks and every one of these works fine, it is just Lord of the Rings that is causing problems.

    This must be some sort of corruption of the book file, but i have tried to re-download it multiple times and still encounter the same problem. Sometimes it shows up with a red box that says something to the effect of "error at line (some #) encoding error" but I cant copy down what it says because the app crashes too fast.

    Is there any way I can get a working copy of the book or am I just screwed? Any help is appreciated, thanks!
     
  2. macrumors 68020

    LizKat

    #2
    Go in iTunes Store, access your account, access purchase history, report the problem. Or if you have email on the purchase (receipt) i believe there is a link to report problem there as well. You get auto-reply and a case number, they respond in a day or so. Of course then they have to look INTO it, which can take awhile. I'm waiting 4 weeks and counting on a corrupted movie file. They may credit you in the meantime and let you repurchase if it's corrupted on their end.
     
  3. macrumors 68000

    -tWv-

    #3
    Turns out it was a jailbreak issue, apparently the changes the jailbreak makes in the file system messes up ibooks. After a restore all the books work fine.
     
  4. macrumors 65816

    #4
    OP, did you end up not installing the jailbreak just so that your iBooks works? I am jailbroken and am having display issues with colored books.
     
  5. macrumors member

    #5
    I'm having the same issue however it doesn't crash every time. Were you using RetinaPad at all? I was using it and once I uninstalled it my crashes stopped happening as often.
     
  6. macrumors 68000

    -tWv-

    #6
    Yes, I did a full restore and everything works as normal now. It must be an issue with the jailbreak that makes things not show up correctly.

    I was using full force, not retina pad. Guess I should have tried to uninstall that but I just ended up doing a restore instead. I don't really need a jail broken iPad anyways
     

Share This Page