Saving new contacts by default into Exchange

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kinson7, Apr 28, 2011.

  1. kinson7
    Expand Collapse
    macrumors newbie

    Joined:
    Dec 11, 2010
    #1
    Hi guys,

    I've just reset my dad's iPhone and synced it with his Exchange account, since all the contacts are there. The issue is that the default way of adding contacts to the iPhone (via the recent calls or the dialer) saves the contacts locally.

    Is there any good way to have the contacts saved by default to the Exchange instead?

    On a side note, opening the contacts and adjusting it slightly is very slow.

    Thanks in advance!
     
  2. BrianBaughn
    Expand Collapse
    macrumors 68040

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    If his phone is being synced over-the-air with Exchange, then make sure that "Sync Address Book Contacts" is unchecked in iTunes.
     
  3. kinson7
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #3
    I don't sync the contacts via iTunes anymore. There is some sync issue with the contacts that I couldn't solve, so we went to put his contacts in the cloud instead.

    The issue is that despite the (exchange) contacts being synced over-the-air, when you save a contact in the iphone via the dialer/recent-calls, it goes into the iPhone's local contact list by default, instead of into the exchange group. :/
     
  4. blevins321
    Expand Collapse
    macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Olympia, WA
    #4
    I struggled with this for the longest time until I discovered that I was looking at the All Contacts group instead of my Exchange contacts. Click the arrow in the upper left to go back a screen until you see something similar to the attached one. In my case, I have 2 exchange accounts - Personal Gmail (where I keep all mine) and my work exchange that I use just for email searching.

    Go into whatever your equivalent to the Contacts under Gmail is, and add contacts in there. I just tried to close and reopen the Contacts app and it saves your folder between sessions.
     

    Attached Files:

  5. kinson7
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #5
    @blevins321:

    Thanks for the suggestion, it's very useful. I've already done that for my dad, and it works when he saves contacts through the contacts app.

    The main issue is that Apple has made it (rightfully so) very intuitive to save a contact from the dialer or recent-calls menu. all you have to do is click the right-arrow and you'll be able to "add to contacts", which dumps it into the iphone-contacts folder, instead of exchange, regardless of the default contact view in the contacts app.

    I myself don't add contacts through the contacts app, as I normally key in the number in the dialer then hit the "+" button to create a contact :/
     
  6. blevins321
    Expand Collapse
    macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Olympia, WA
    #6
    Found it!!

    I think I found it! :D I don't have a number to test it with though lol. In your mail/contacts/calendar settings, there is a setting under Contacts called Default Account. Selectable are the default On My iPhone and my Gmail (don't sync contacts with my work account). Try switching to the exchange account and get someone to call you from a new number and try adding it.
     

    Attached Files:

  7. kinson7
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #7
    Oh wow! Thats amazing! Thanks a lot man! I'll give it try on Sunday/Monday when I see my dad. It seems logical. I can't find the setting on my iPhone, but perhaps because I don't sync my contacts with an Exchange account (and the setting is hidden).

    I'll report back in a few days. Thank so much! Owe you a drink cuppa :D
     
  8. kinson7
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #8
    @blevins321:

    It works! Thanks man! You're a life saver! I didn't think it was possible, but was just trying my luck here. You're awesome! :D
     
  9. blevins321
    Expand Collapse
    macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Olympia, WA
    #9
    Lol you're welcome. :). That had been at the back of my mind for awhile, and hearing someone else that was annoyed with it gave me an excuse to look.
     

Share This Page