Scanner driver for Epson RX640 issues

Discussion in 'macOS' started by shellbryson, Jan 5, 2007.

  1. shellbryson macrumors 6502

    shellbryson

    Joined:
    Dec 28, 2006
    Location:
    Edinburgh
    #1
    Hi guys,

    I have a problem with the RX640 3-in-1 printer/scanner/copier, and maybe someone in here has some pointers.

    I installed the drivers as instructed under OS X, and the printer works fine. However the scanner only works once, then dies if I switch user accounts. Soon as the other account loads I get a message that the scanner helper ("EPSON SCAN Monitor") cannot find the scanner. If I then switch back to my own account, the scanner no longer works there either. If I totally shut down the machine and restart, it the scanner works again... until I switch users. Doesn't matter which user I start up with, soon as you switch the scanner is buggered.

    I've tried totally removing the drivers, reinstalling them, downloading latest updates for the driver... and I'm lost for what to try next. Any suggestions?
     
  2. Halcyon macrumors 6502

    Joined:
    Sep 21, 2006
    #2
    This is not going to help solve your problem...but if misery loves company :)

    I have a Epson 1260 Perfection Photo scanner and sometimes (almost all the time) I can scan only one or two images before I have to shut down the scanner and start all over again because I get an error message saying that the scanner can't be found...or the software simply closes by itself. This will happen no matter what if I scan one image and then go on to do something alse (switch programs, check my mail, etc.), but if I stay within the Epson scanning software I can continuosly scan several images (even then this is only sometimes and not all the time).

    This has to be a bug as several other friends with similar setups (Epson scanners on Mac OSX10.4.4 and higher) have the same problem. I've also downloaded latest drivers and software versions...

    Maybe somebody else will post something that can be useful.

    Halcyon
     
  3. shellbryson thread starter macrumors 6502

    shellbryson

    Joined:
    Dec 28, 2006
    Location:
    Edinburgh
    #3
    Seems along similar lines of my issue. Intel Mac, yes? I think the driver either doesn't exit properly once you have scanned something, and/or if you have multiple accounts the Scanner Monitor software conflicts.

    I've emailed Epson technical support. I need a solution for this, or the printer is heading back to Apple (where I bought it) next week. It says on the side of the box it is Mac Universal, but it's blatantly not been well tested (googling results in many people with the same issue with Epson scanners, an no solution).
     
  4. shellbryson thread starter macrumors 6502

    shellbryson

    Joined:
    Dec 28, 2006
    Location:
    Edinburgh
    #4
    The Epson drivers do NOT support fast user switching. Something to do with driver communication. If you LOG OFF the current user and log into a second user afresh, it's fine. Which is not a solution really...
     
  5. Halcyon macrumors 6502

    Joined:
    Sep 21, 2006
    #5
    Was your last post based on a response you got from Epon Tech Support?

    Like you said, it's not an acceptable solution, so I'm wondering if they will come out with a patch.
     
  6. shellbryson thread starter macrumors 6502

    shellbryson

    Joined:
    Dec 28, 2006
    Location:
    Edinburgh
    #6
    I fired a mail back to Epson. I'll call Apple Tech support tonight as well (or their sales team). They can either; fix the driver, replace the printer, or buy me a copy of VueScan. Not happy. Wondering how Epson can qualify for the OS X/Apple logo on the box for the printer if it blatantly doesn't work with one of the key features of the OS...
     
  7. Halcyon macrumors 6502

    Joined:
    Sep 21, 2006
    #7
    Hmmm...my following question could possibly be considered a new thread...

    What other software (third party) is out there that can replace Epson's?

    Google search turns out various: ArtScan, VueScan, Silverfast, etc., but it would be nice to get feedback from somebody with first hand experience on any of them.
     

Share This Page