Screen shifts to a blue tint when on discrete graphics

Discussion in 'OS X Mountain Lion (10.8)' started by shigatashway, Jul 28, 2012.

  1. macrumors member

    Aug 29, 2011
    Since updating to ML, whenever the discrete graphics card kicks in, the color shifts to a blue/cool tint. I have gfxcardstatus installed with growl (so it shows a little alert whenever the graphics switches), and it happens every time the graphics switch to discrete, and only then. Curious if anyone else is seeing this happen on their laptop? Mine's a late-2011 15" - if it might be hardware specific.

    To me it seems like for whatever reason the color-scheme is jumping around when the discrete is on. I tried playing around with the screen calibration, and whenever the discrete was on, the blue-shift option made absolutely no change. :confused:
  2. macrumors regular

    Jul 12, 2008
  3. macrumors newbie

    Jul 29, 2012
    Im getting the same issue

    Im getting the same issue I have a 3 month old mac book pro 17in and the same thing happens I did not know it was when the graphics card came on but now that you have said I realised that is whne it happens to me.
  4. macrumors newbie

    Mar 1, 2013
    I just started having this happen after a clean install of ML on a new SSD. Here's (I think) how I fixed it. I was trying so many things, so I apologize if this doesn't exactly work for you. But it's definitely possible to get auto-graphics switching without the color-temp changing.

    1. With no other programs open (after a fresh reboot is probably best), calibrate your monitor as you like it under System Prefs -> Display -> Color
    2. Turn off auto-graphics switching under System Prefs -> Energy Saver
    3. Reboot
    4. Navigate to /Library/ColorSync/Profiles/Displays and delete any profile that isn't your newly calibrated display profile. (In my case, two "Display" profiles were showing up)
    5. Reboot
    6. Turn on auto-graphics switching under System Prefs - Energy Saver
    7. Reboot

    I think that should do it. I realized that it was impossible to separately calibrate the discrete graphics card because whenever it opened up the calibration application, the computer would switch back to the integrated graphics card.
  5. macrumors newbie

    Dec 30, 2014
    hey baronvonfunboy!

    thanks a lot for your idea, but your solution has worked partly for me (OSX 10.10.1 MBP 2010 i7), but based on it I've found the one, that worked for me.

    I could reproduce blue tint for 100%, while in Energy Saver options I clicked on the Automatic Graphics Switching checkmark. when the system was switched to GeForce card, the blue tint has appeared.

    Your steps worked perfectly, but after the final step (enabled Graphics Switching back again) I've rebooted one more time and this blue tint issue was back.

    So, what I've noticed on my machine:
    - if you reboot with Automatic Graphics Switching checkmark off, you have no blue tint and even playing with this checkmark after reboot doesn't show up the blue tint
    - if you reboot with Automatic Graphics Switching checkmark on, after reboot you have the same issue with blue tint appearing when switching to discrete graphics card

    So, I've ended up with turning off Automatic Graphics switching, until I need any critical battery lifetime.

    Hope this will save some time for somebody.

Share This Page