Screen washed out on new MacBook Pro

Discussion in 'MacBook Pro' started by Muds, Jan 2, 2009.

  1. macrumors newbie

    Jun 5, 2008
    Just wondering if anyone else is having problems with their unibody Macbook pro screen getting washed out after a while - especially if the computer has been put into and woken from sleep.

    I run a 24 inch dell monitor along side my MBP in dual monitor mode, the MBP the slave monitor, with the Dell the main monitor. After a while of use, approx 2 hours, the macbook pro screen fades out/appears washed out. It seems to settle after either a restart or dimming the MBP screen to black for a few minutes.

    My MBP is not on a cooling stand but I'm going to get one

    Is this a heat thing, a firmware thing or a defective hardware?

    I'm running 10.5.6 and have updated the firmware/efi as per apple updates.

    Any ideas?

  2. macrumors regular

    Sep 9, 2007
    I think I know what you are referring to. I also get this effect like you after using the laptop for a while. I have not seen any problems from my late 2007 MacBook Pro model. If I do find something out though I will post back.:apple:
  3. macrumors newbie

    Jul 1, 2009
    Cheshire, UK
    I have exactly this problem, made more obvious because I have an additional desktop monitor next to my MBP. The monitor has rich colours but the MBP looks washed out. It happens intermittently and as far as I can tell bright light is the cause, for example on a sunny day.

    The solution seems to be to go to System Preferences-> Universal Access and click on the "Enhance contrast" slider.

    In my case the slider is always set to "Normal", all the way to the left, but just clicking on it corrects the problem even though the slider does not move.
  4. macrumors 65816

    Andrew K.

    Jul 9, 2008
    Mine was washed out too and had a yellowish tint, a calibration helped the colors but not the washiness of the blacks and some negative viewing angles. I'm already setup for repair.
  5. macrumors G3


    Mar 20, 2007
    Make sure you are using 2.2 gamma. Helps a lot.

Share This Page