second hard drive spinning up and down

Discussion in 'General Mac Discussion' started by jkaz, Dec 7, 2004.

  1. jkaz macrumors 6502

    Joined:
    Feb 3, 2004
    Location:
    Upper Mid West
    #1
    recently, for the first time, i told my computer to shot off hard drives to save energy. (2001 800mhz dp g4)

    not too long ago, i told my computer to keep the hard drives on.(i have 2)

    it seems that the sys files drive stays on, but the other drive likes to spin down.


    anyone know how to make it stay back on again?

    i've tried some of the basics in disc utility as well

    thanks!
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    If I follow what you're describing, you enabled the "Put the hard disk(s) to sleep" option in Energy saver, at which point your 2nd hard drive would periodically spin down if you weren't using it. This is, of course, the expected behavior (the main drive can shut down as well, but much less frequently since it gets used a lot more).

    You then unchecked that option, but your 2nd drive is still going to sleep, correct?

    First, what version of the MacOS are you running? I know there was a bug in an older version (can't remember which) that basically made that checkbox useless--the drives would sleep regardless of your setting. If you're on 10.3, it should work, but in truth I always have that turned on, so I don't know if turning it off works for secondary drives or not.

    You might try finding and trashing the Energy Saver plist file and see if that helps. You could also try resetting the power manager using the motherboard button or Open Firmware.
     
  3. jkaz thread starter macrumors 6502

    Joined:
    Feb 3, 2004
    Location:
    Upper Mid West
    #3
    Makosuke

    Thanks for the reply

    i'm running 10.3.5(haven't run update for a while, i know)

    was wondering, though, how to find that plist file to trash it

    thanks!
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    Well, things like that are usually in the Preferenes folder in either your system Library (the one at the top level of your startup drive) or the library in your Home folder.

    I'd expect it to be called something like com.apple.energysaver.plist, but I just did a quick search and didn't find anything that looked at all like it. Perhaps the settings are saved directly to the power manager and/or NVRAM? Maybe someone more knowledgeable will chime in.
     
  5. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #5
    I believe its called com.apple.PowerManagement.plist

    Full path is /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist
     
  6. jkaz thread starter macrumors 6502

    Joined:
    Feb 3, 2004
    Location:
    Upper Mid West
    #6
    thanks for all the help.

    found the document, but i'm going to wait until it happens again to give it a try as i have done the old set prefs and reboot as i do a full shutdown of my computer maybe once ever 7 months.

    if it comes up again, though, i will trash the pref file.

    but to make this more clear, i can simply throw the file away and all is good?

    thanks!
     
  7. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    Well, you can throw it out and it won't break anything, though you'll have to re-set the preferences.

    Whether it'll actually do any good or not, I'm not sure, but it won't hurt to try.
     
  8. jkaz thread starter macrumors 6502

    Joined:
    Feb 3, 2004
    Location:
    Upper Mid West
    #8
    updated and clarification:

    i've removed as much stuff from both of my harddrives as possible,

    ran software update

    and now have energy saver set to keep hard drives running no matter what

    however, my hard drives are still going to sleep despite the settings and my wishes

    anyone know what is going on?
     

Share This Page