Serious Excel Problem - Missing Formula Bar

Discussion in 'Mac Apps and Mac App Store' started by croberts134, Mar 22, 2006.

  1. croberts134 macrumors newbie

    Nov 3, 2005
    I use Excel 2004 about 7 out of 8 hours a day at work. Tonight I accidentally clicked on the formula bar and dragged it somewhere. I can't find it anymore! I quit every program except excel in an attempt to find it hiding somewhere but its nowhere to be found. I've tried unclicking "Formula Bar" under the View menu and then reclicking it but the formula bar doesn't reappear. Having the formula bar is vital to my day. Help!
  2. nutmac macrumors 68030

    Mar 30, 2004
    Perhaps deleting Excel preferences (e.g., rm ~/Library/Preferences/Microsoft/*xcel*) will do the trick.
  3. iSaint macrumors 603


    May 26, 2004
    South Mississippi y'all, near the water!
    You might also close the window you're working on. Sometimes things will hide behind them when moved.

    Can you see a button like what is at the top left of each toolbar partially hidden somewhere?

    Attached Files:

  4. Togglehead macrumors 6502

    Mar 16, 2006
    is there a "customize toolbars" option anywhere? it probably just got hidden somehow, and needs to be reenabled.....=]

    at least in PC that happens, click on tools, or options.....something like that
  5. Dunepilot macrumors 6502a


    Feb 25, 2002
    Yes, I'd suggest you look behind other toolbars. This happened to me in Word 2004 today. Really foxed me.

    Try closing all the toolbars apart from the one you want, and see if that helps.
  6. croberts134 thread starter macrumors newbie

    Nov 3, 2005
    I went for the quickest easiest fix and trashed my Excel preferences. Then I reopened Excel and it was back. I hadn't made too many changed to the preferences anyways so I don't even notice the difference.
  7. Jen G macrumors newbie

    Jan 28, 2008
    Alternate fix for hidden Excel formula bar

    My formula bar was hiding all day today, driving me crazy. I'm on Mac Leopard. None of the above listed solutions worked. For a while I had no idea where it even was. Then, when I was in a cell with a lot of text, the end part of the text was showing at the top of my screen, so I realized that the top of the formula bar (the draggable part) was hidden way off-screen--it was impossible to drag down because the cursor thinks you're trying to do something on a regular menu bar. Aaarrggh!! Finally, I went into System Preferences (NOT Excel prefs!), changed the screen resolution to something lower, and voila! My formula bar was revealed. Then I dragged it down to the middle of the screen before putting the display resolution back to what it usually is. FIXED!
  8. jamot macrumors newbie

    Dec 1, 2008
    Dual monitor case

    In my case, the formula bar is stuck out of the left hand side of the screen. Unfortunately, Jen G's solution does not work. Whenever I switch the resolution, the formular bar always stays just outside of the screen. However, due to hints from his idea, I have solved my problem.

    If you are using dual monitors and the formular bar is stuck just outside of the left hand side (so you can not grab a handle to move the bar), try the followings.

    Change the position of your two monitors in System Preferences -> Displays ->Arrangement and, if it would not help, switch your main monitor by moving the menu bar (on the top of small monitor icons) in the same preference panel. That would solve the problem.
  9. doray macrumors newbie

    Jan 10, 2009
    Excel formula bar stuck off left side of screen

    I too had the problem where my formula bar was stuck off the left side of the screen. (I have a Mac and am using Office 2008, Excel 12.1.5.) I have Excel set up the way I want and didn't want to trash preferences. To fix the problem, I didn't have to. I just trashed ~:Library:preferences:Microsoft:Office 2008:Excel Toolbars (12). Make sure you close Excel first....
    Hope that helps.
  10. annic macrumors newbie

    Jan 27, 2009
    Missing formula bar

    I have the self same problem as this on Leopard and Office 2008. The problem I have is that I keep seeing that the answer it to trash Library:preferences:Microsoft:Office 2008:Excel Toolbars .... but I can't find that file ANYWHERE and believe me I have looked. Can someone point me in the right direction before I lose what little sanity I have left??

    Any help would be MUCH MUCH appreciated - and I apologise if I am being stunningly dense

    Thanks in advance for any help!

  11. sandyjim85 macrumors newbie

    Jan 27, 2009
    Ctrl + Shift click to open

    I had exactly the same probs as the last post, couldn't find the preferences file in the library. I found the solution on another forum, hold down control and shift when you click the excel icon to open it... it worked for me. It must open it with standard settings or something :)

    Hope it helps!
  12. annic macrumors newbie

    Jan 27, 2009
    YOU ARE A COMPLETE STAR! It worked it worked! Thank you soo soo much for saving my sanity. I will remember this!

    Thanks again

  13. sandyjim85 macrumors newbie

    Jan 27, 2009

    OK, so now my previous solution is *not* working for me... I don't get it :confused:
  14. doray macrumors newbie

    Jan 10, 2009
    location of Excel Toolbars file

    When you look for the Excel Toolbars file, make sure you're looking in your user library, not the "main" library. Also, you may or may not have an Office 2008 folder -- it could just be in the Microsoft preferences folder.
    Again, the location is:
    ~:Library:preferences:Microsoft:Office 2008:Excel Toolbars
    where ~ means it's within your user folder.
    Good luck!
  15. chris100 macrumors newbie

    Apr 15, 2009
    Missing formula bar in excel

    I don't know about Excel 2004, but in previous versions of excel the formula bar is a setting, not a toolbar. Try 'Tools' > 'Options' go to the 'View' Tab and check the 'Formula bar' box.
  16. jonmay macrumors newbie

    Jun 15, 2009
    Change screen resolution

    I use two different sized monitors at home and at work, but just my laptop on the train, and Excel / Word are forever losing floating palettes or windows, hiding the tops behind the menubar, or refusing to make document windows fill the screen.

    I've tried deleting preferences, even editing them in BBedit, but have found that simply changing screen resolution usually brings things back on screen. I have set my System Preferences > Displays to show the little monitor icon in the menu bar, so I just change to the next smallest resolution and back again.
    It is worth trying this before you start deleting things from your Library.
  17. tjmaryland macrumors newbie

    Jul 22, 2009
    Washington DC area
    Missing formula bar in excel

    Annic's posting - Jan 27, 2009, 12:59 PM - worked for me. Thanks
  18. August51 macrumors newbie


    Nov 17, 2009
    A Combination worked for me

    Thank you all for all the suggestions and testing, etc.

    I have a laptop and a larger monitor, laptop at left, monitor at right, and I could see ONE PIXEL of the right edge of the formula bar where the monitor sticks up above the laptop screen. Sometimes I could grab that and stretch it out to be partially visible, but that did not get me access to the left end where I could move it.

    Switching sides, switching where the main toobar is, did nothing except sometimes put the whole Excel window out of view and immovable.

    Thanks to all the suggestions here, what finally worked for me was to:
    1. Turn OFF the Formula Bar.
    2. Close Excel.
    3. Change resolution on both screens to about 2/3 what they had been.
    4. Delete the $HOME/Library/Preferneces/.../Excel Toolbars (12) file.
    5. Open Excel.
    6. Turn ON the Formula Bar. Yay, it's visible.
    7. Close Excel.
    8. Restore the screen resolutions.
    9. Open Excel again. And there it is.
    Of course, YMMV. Good luck.

    I hope this helps,
  19. twfmike macrumors newbie

    May 29, 2008

    Thanks annic,

    Cntrl & Shift did the job, I have been climmbing the bloody walls for 3 hours trying to fix this.
  20. macadministrabl macrumors newbie

    Nov 3, 2010
    Office 2008 missing Formula bar

    Here's what I've found from working with one of my users.

    Symptoms : In Excel 2008, with "View -> Formula Ba" being checked you don't see a formula bar. Closing all other windows except for excel and you still don't see it. Changing aspect ratio and even plugging into another external monitor and you don't see it.

    Probable Cause : If you plug into an external monitor/projector and are mirrored and use Excel 2008, you can lose your formula bar when you unhook. Whether or not you close the lid while hooked up to the projector or not I don't know.

    To get it back, deleted all instances of plists in home library Preferences directory.

    This worked because the user only had default settings and didn't care.

    Only one of the plists is probably the culprit, but at this time don't know which one and it didn't matter to the user as she only used default settings so deleted them all.

    Result : User had to agree to being Microsoft user again mostly like when first time using Office. Restarted Excel cause it closed when finished with that step.
    Formula bar came back up fine.

    She isn't mirroring anymore on external display devices so hopefully won't see this problem anymore.

    Command line commands used :

    $ cd ~/Library/Preferences
    $ rm*plist

    Again, this will delete any custom settings you have, but for most people they won't care.

    I'd love to find out which plist in particular does it.
  21. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    Well, you blew your opportunity I guess.
  22. salmonupstream macrumors newbie

    Jul 8, 2011
    Shift Control worked for me as well. I love web forums. Thanks for the various solutions offered.
  23. Garoolgan macrumors member


    May 24, 2012
    In France, 25th on UN's HDI list of countries
    I just lost the formulae bar on Excel 2008 for Mac and finally noticed a thin double line below the Menu Bar going the whole length of the screen.

    After trying to shorten the right hand corner of the bar (only just visible) with no result I saw a lighter patch of this hidden bar on the left hand side of the screen and was able to pull the formulae bar down with the mouse by putting the arrow on the light patch and pulling down..

    How on earth I managed to tuck the formulae bar up there in the first place I don't know but I'm not going to try again just to have you guys laughing at me even more!!

    I hope this helps someone


Share This Page