serious pb display problem. pic included

Discussion in 'Macintosh Computers' started by gjg554, Jun 7, 2004.

  1. gjg554 macrumors newbie

    Sep 26, 2003
    I am having a serious problem with my powerbook g4 17" display. I cant even describe it, look at these pics[​IMG] [​IMG] Notice the strange bar like collumns running down the pictures, and the dirty looking brushed metal. Also look at the lines. What can be causeing this? You might not even be able to see the problem, cause the captured images are showing it, but on my computer those pics have the problems
  2. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    could you take a digital picture of the display rather than a screenshot?

    That would really help a diagnosis. I see no problem other than elements not in the place I would expect them.
  3. gjg554 thread starter macrumors newbie

    Sep 26, 2003

    the digital camera isnt taking the picture right so I will try to explain what happened. I was working on my computer, when all of a sudden the color started to jumble up and change colors, gradulally it became lighter with pixels all over the place. I turned it off and then on to find my desltop streaked with collumns of clear and black bars. Lines go through icons, the shadow of windows are lines that do not disappear. The brushed metal also looks like a dirty kind of brown. The colors also get very blocky. When trying open a program the icon looks like it is in a square. This is very strange.
  4. russed macrumors 68000


    Jan 16, 2004
    London, England
    well surely it cant be a problem with the screen itself because otherwise you wouldnt be able to take a screen shot of my guess is that is it something to do with the graphics card.

    give the laptop a hit and see if it sorts it out! :D
  5. Calvinatir macrumors 6502


    Nov 8, 2003
    my video card for my old PC did that when it broke, we replaced it and it went back to normal...I have the 17 PB..hope that doesnt happen to mine!
  6. gjg554 thread starter macrumors newbie

    Sep 26, 2003

    wow thanks. i took the battery out and pushed in the compartment. Everything is fixed

Share This Page