Shared Machine Access

Discussion in 'OS X Mountain Lion (10.8)' started by Hawnted, Nov 16, 2012.

  1. Hawnted, Nov 16, 2012
    Last edited: Nov 16, 2012

    macrumors newbie

    Joined:
    Oct 27, 2012
    #1
    I am a new Mac user, got my first Mac (Macbook Pro) last month. I have since switched my Windows Home Server to a Mac Mini running OS X Server. I have set up all the file sharing, remote access, Shared iTunes Library, backing up my Macbook to the Server etc. However, one problem occurs pretty frequently that I cannot seem to resolve.

    If I open a new finder window on my Macbook Pro, and select the server from the "Shared" section on the left sidebar, I always get "Connection Failed". Also no Screen Sharing button is available. If I actually select "Go->Connect to Server" I can connect fine using domain name, hostname, or IP. Sometimes after I go this route, I can select the machine from the left sidebar, it will connect fine, and I get the Screen Sharing button. Sometimes not. Seems rather flaky.

    Any advice? I found this post but it did not resolve my issue.
     
  2. macrumors 6502a

    Joined:
    Sep 10, 2012
    #2
    RE: shares...

    Hi Hawnted,

    Have you checked the permissions for your user account in the File Sharing pane of the Server.app, as well as the Settings (Share with Mac clients)? Your exact username must be the same as the one you are attempting to connect to on your server, if not then you will get the "Connection Failed" message since by default it attempts the connection using your local username. Are you using Open Directory? Sometimes there is confusion between the account's username (short name) and the Long Name. Click on the "Connect As..." button after it has failed the first time and enter your username (short name), not your Long Name, and your password and check the "Remember this password..." button. If your permissions are setup correctly, this should correct your problem of not being to connect via the left-hand sidebar in a Finder window.

    I believe what happens is when you use "Go->Connect to Server" you are presented with a login screen that allows you to authenticate to your server (Kerberos) --- this works, and once authenticated your "Connect as..."/"Disconnect" and "Share Screen..." buttons become available in the left-hand sidebar of the Shared section when you click the button for your server.

    If you wish to use screen sharing often, then I would add the Screen Sharing.app to your Dock, that way you don't have to use the Finder's sidebar. The Screen Sharing.app is in the /System/Library/CoreServices directory...just drag it to your Dock and an alias will be created for it on your Dock.

    Good luck,
    Switon
     
  3. thread starter macrumors newbie

    Joined:
    Oct 27, 2012
    #3
    Thank you for your suggestions. I checked all the permissions, the accounts, etc. I am not using open directory. My accounts on each computer have the same long and short name, as well as the same password. If I hit the "Connect As" button nothing seems to happen, which is perplexing. Maybe I need to clear out my Keychain?

    I am utilizing your workaround for the time being (adding to the dock). Do you know what the permissions should be? I have given my account (that is the same on both computers) Read/Write to all shares, and Everyone has Read Only on Public, Users, and Groups, and NO ACCESS to all others.
     
  4. switon, Nov 16, 2012
    Last edited: Nov 16, 2012

    macrumors 6502a

    Joined:
    Sep 10, 2012
    #4
    RE: permissions...

    It sounds like you have setup the permissions correctly. Depending upon how many files you have, sometimes changing the permissions on a volume can take quite awhile, time-wise. Did the propagation of permissions finish in the Server.app before you quit it?

    Do your accounts on each machine have the same UserID and GroupID numbers? Even though they have the same name, sometimes they may differ in UID and GID. You might also try Open Directory, as it might clean up any inconsistencies between your accounts. You can still keep your home directory on your laptop under OD, or transfer it to the server. (I use OD on a Mac mini Server with success in a situation similar to yours.)

    And, of course, reboot both machines, especially the server, before proceeding.

    Switon

    P.S. When you hit the Connect As button, if it fails it will take quite some time because various "timeouts" have to pass before it returns with a "Failed".

    ----------

    Hi,

    You might also temporarily give everyone R/W access to a share just to see if you can then connect to this share. You might also try connecting using SMB (turned on in the Server.app File Sharing Settings pane), just to see if this works. I'm running out of ideas to try...sorry.

    Switon
     
  5. thread starter macrumors newbie

    Joined:
    Oct 27, 2012
    #5
    Will open directory force me to use a password to login to the macbook pro?
     
  6. macrumors 6502a

    Joined:
    Sep 10, 2012
    #6
    RE: login...

    Hi,

    Are you not now using a password to login to your MBP? I think this is a dangerous standpoint, from a security point of view. If you really don't want to login to your account, then I would suggest setting up a strong password, logging in once, and never logging out. Use sleep mode instead of turning your MBP off. I've heard some people have used sleep mode for months at a time without problems.

    I do not know off the top of my head if OD will force you to use a password, as I have never attempted using OD without passwords. But I suspect that since OD has a number of password policies that must be established then you will be required to use a password to login. In addition, I think it would be even more dangerous to setup an OD account without a password. You can Kerberize your OD so that you only have to login once and then all subsequent authorizations will be automatically handled without you needing to type in your password again.

    Switon
     
  7. thread starter macrumors newbie

    Joined:
    Oct 27, 2012
    #7
    It seems to have been a DNS issue. I could not ping SERVERNAME.local, but I could ping domainname.com, and IP. I then pointed at the server for DNS, and instantly was able to connect via the sidebar.

    Thank you for your assistance.
     

Share This Page