Sharing a connection

Discussion in 'macOS' started by harveypooka, Jan 21, 2006.

  1. harveypooka macrumors 65816

    Joined:
    Feb 24, 2004
    #1
    I'm sharing a connection from an iMac via it's wireless card and it cannot access the net via my iBook. It picks up the wireless signal fine and allows me to enter the password but doesn't let me access any pages...any ideas? Personal web sharing are active on both machines, I've tried disabling the built in firewall on both. Both run MacOS 10.4.3.
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Personal web sharing turns on the built in webserver. It does not share an internet connection. Internet sharing (the third tab in the Sharing preferences pane) does this. You need 2 interfaces to do this. I.e. your Mac need to connect to the internet via ethernet or USB to share out the connection on Airport.
     
  3. harveypooka thread starter macrumors 65816

    Joined:
    Feb 24, 2004
    #3
    Hi Rob, I've done all this. The iMac has a connection via a USB modem and I enabled Internet Sharing. When I enabled it is came up with a message telling me to enable Personal Web Sharing, which I've done. Still no joy. Any ideas?
     
  4. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #4
    On 10.4.4 I just tried turning on Internet sharing and it said nothing about turning on web sharing. Try stopping all sharing services on the iMac and turning off the firewall. Then turn on Internet sharing.
     
  5. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #5
    On the iBook, try going into Network preferences for airport, select the tcp/ip tab, and hit 'renew DHCP lease' - I'm no expert, but I think this will renew your ip address on the ibook, which should allow you to connect, assuming you have everything set up right.
     
  6. harveypooka thread starter macrumors 65816

    Joined:
    Feb 24, 2004
    #6
    Ok, done that. Still no joy. Look at the bottom of the Internet Sharing panel is has an exlamation mark sign with the text "Other settings may conflict with Internet Sharing" with an option for 'More Info'. When you click this it then says "Enable personal web sharing in the services pane...". The message doesn't pop up, but is there....still no connection though.
    I'm running 10.4.4 on the iBook, forgot.
     
  7. harveypooka thread starter macrumors 65816

    Joined:
    Feb 24, 2004
    #7
    No joy either!
     
  8. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #8
    And you have all that 'Share my internet connection through USB with computers connected via airport' malarky set right, yes? And you have 'personal file sharing' and 'personal web sharing' checked in the services pane?
     

Share This Page