sharing printer on airport base.

Discussion in 'General Mac Discussion' started by str8_ballin, Jan 25, 2004.

  1. str8_ballin macrumors newbie

    Jan 25, 2004
    Need assistance here. Just bought a powerbook g4 and airport base station. I have an hp psc 2110 printer plugged into the airport base station. Setup the printer through the mac and works just fine. Current windows computers can't see hp printer over network.

    Here's my current setup. Cable modem connected to wan port of a Linksys 4 port swith. I have a windows 2000 laptop connectted into port 1. Windows xp machine connected into port 2. Port 3 connects to the Airport base station. Using a workgroup to network computers. I can ping the mac from both pc's. and mac can ping pc's. I can connect to the hard drives of both PC's from mac. I can also connect to HD on mac from both PC's. Just having a problem sharing the printer with the PC's.

    Any help or direction to document that would remedy my situation would be great!!

  2. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    So you can't print through the AE base station with the PC? Do do this you need Rendezvous, which Windows doesn't have. So AFIK only OS X computers can print through the AE base station.
  3. Nik_Doof macrumors regular

    Sep 15, 2003
    St Helens, UK
    Get HP JetDirect installed on ur Windows machine (if its below Win2000), add a new printer, create a new port...

    Select TCP/IP Port or JetDirect Port... put the IP address of the AE in and make sure the port is 9100.

    Wolla :)
  4. str8_ballin thread starter macrumors newbie

    Jan 25, 2004

    :) Hey, nevermind guys, but thanks for your help though. Problem is solved. Actually was pretty simple.

    Have a good day!
  5. ftaok macrumors 601


    Jan 23, 2002
    East Coast

    Please share with us the simple solution. Who knows, you might help someone else out who's having this problem.

  6. str8_ballin thread starter macrumors newbie

    Jan 25, 2004

    On the airport base station, i unchecked the distrubt ip addresses. so with that said.....

    1.Make sure the printer is recognised by the base station.
    2.Select 'Add a new printer' in Windows
    3.Select 'Local Printer' in the dialog box (auto detect and install should be off), click next.
    4.Choose 'Create a new port' and "Standard TCP/IP Port'. Click next.
    5.For the printer IP address, enter the address of the base station ie. or in my case The port name will be filled automatically. Click next.
    6.For the device type, choose 'Hewlet Packard Jet Direct', then click Finish.
    7.Choose your printer from the list and follow the rest of the prompts to install and configure the driver.

    In my case my printer didn't show up under the hp printers. So i had to search the hp site to find a compatible printer that i could use. It was different for the windows 2000 and windows XP PC's. I selected thoses printers, clicked test print and BAM!!!! SUCCESS!

    Hope this helps some of you out.
  7. Sabenth macrumors 6502a


    Jan 24, 2003
    thanks guys you just solved a problem i was having with my printer with windows too hahah:D
  8. Nik_Doof macrumors regular

    Sep 15, 2003
    St Helens, UK
    Re: solution!!!!

    basiclly like i said above :)

Share This Page