Simpletech External Hard Drive not working on new Macbook Pro

Discussion in 'MacBook Pro' started by battrcake, Aug 13, 2012.

  1. macrumors newbie

    Joined:
    Aug 13, 2012
    #1
    Hi,

    I recently purchased a Macbook Pro after having an iMac for about 5 years. I've been backing up all of my files on the iMac with a Simpletech "Black Cherry" External Drive (360 gb) for about 3 years and was looking forward to transferring a bunch of these files (mainly my music) to the new Macbook Pro. For some reason, the Macbook Pro will not recognize the external drive. I looked up information on what the drive should be formatted as, and this drive was formatted as "Mac OS Extended (Journaled)." Apparently, this should allow the drive to be read on other Mac computers, but that isn't the case for me. The drive is recognized immediately on my iMac, but when I plug it into the Macbook the red light turns on and nothing else happens. Should I just reformat the drive as "exFAT" for this to work? Does anyone have experience with this?

    Thanks.

    ETA -- my Macbook Pro is the 13" model, not the new 15" with retina display.
     
  2. macrumors 603

    Joined:
    Feb 20, 2009
    #2
    "The drive is recognized immediately on my iMac, but when I plug it into the Macbook the red light turns on and nothing else happens."

    Is the drive a 2.5" or 3.5" drive?

    Does the drive's external enclosure have a port for plugging in a power brick?

    It's a USB drive, is this correct?

    My guess is that the drive requires more "USB bus power" than the MacBook provides. The result will be either:
    1. Connect the drive and.... nothing -or-
    2. Connect the drive and it may spin, but not mount on the desktop.

    The iMac is probably providing enough bus power to get the drive up and running, whereas the MacBook does not.

    The solution is to use an external power supply with the drive when connecting to the MacBook.

    If you connect the drive to the MacBook, do you get any kind of error messages? Or, just nothing at all?

    If you connect the drive to the MacBook, and open Disk Utility, what does it say?
     
  3. battrcake, Aug 13, 2012
    Last edited: Aug 13, 2012

    thread starter macrumors newbie

    Joined:
    Aug 13, 2012
    #3
    I'm not sure if it's a 2.5" or 3.5", but here is the exact drive's Amazon page: http://www.amazon.com/Signature-Black-Cherry-external-drive/dp/B0012R9WHW

    I don't get any error messages when the drive is plugged into the pro. It spins but doesn't mount and only the red light is visible. You are probably right about the bus power, which is frustrating since the only thing that came with this drive was the USB (no adapter).

    There is a second port, which I am assuming can be used to plug in a power brick. Since there is no adapter that came with this drive, and I don't know where I put my user manual, I'll have to do more research and may be talk to Simpletech's "tech support."

    Thanks!
     

Share This Page