Skype won't open

Discussion in 'Mac Applications and Mac App Store' started by NickD, Nov 9, 2007.

  1. macrumors 6502a

    NickD

    Joined:
    Mar 25, 2007
    Location:
    Colorado
    #1
    Ever since I upgraded to Leopard, Skype won't open. It'll bounce in the dock 2-3 times and then nothing.

    The only possible way I can get it to open is to re-download the DMG file and then reinstall. It'll only open once, and then nothing else.

    Anyone else have this problem or know how to fix it?
     
  2. macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #2
    If you visit skype or google around, you'll find that it's a known issue and that they are working on it. At the moment Skype is not really compatible with Leopard with the firewall enabled.

    Something about Skype not having followed apple's guidelines on implementing their program or somesuch thingie.

    Anyhows, if you have the problem, the only way you can get it to work is to reinstall it every time you activate it after the first time.

    PS - no need to redownload unless it's a new version, just reuse the dmg file.
     
  3. macrumors newbie

    Joined:
    Aug 28, 2007
    #3
    Yeah, I'm suffering from this too, it's quite annoying.
     
  4. macrumors newbie

    Joined:
    Nov 10, 2007
    #4
    Solution

    No worries people.... start fresh:

    delete application, download Skype.dmg file fresh

    TURN OFF Firewall

    do your install per Skype instructions

    go back to Firewall...notice Skype is now listed in the "allow applications" box

    TURN ON your Firewall

    Should work fine

    When calculators first came out, we were worried we would forget to add and subtract.

    Apple has made it soooo easy to use their stuff, it does everything for us, that we forgot what it was like when we all were part of the evil empire (Windows). Whenever you install a new application in Windows, the message always appears: "Disable Anti-Virus and Firewall Applications because it may interfere with installation." Well guess what......

    Alright everyone, now go back to being creative.
     
  5. macrumors regular

    Yuppi

    Joined:
    Aug 6, 2007
    #5
    It is not like Skype did not follow an convention that was well documented. In fact Apple did "break" something and Skype now has to make it compatible again.
    The thing is that the previous firewall was port based, while the new firewall is application based. In order to ensure that the application that was allowed is the application that is trying to do something Mac OS X signs an application if it does not have a signature yet. So it modifies a file of the skype app by adding the signature.

    Skype and World of Warcraft on the other side do verify that they were exactly the same contents as when they were installed. But as Leopard modified them they fail.
    Apple put on a document about this behaviour http://docs.info.apple.com/article.html?artnum=306938
    It seems to me that the new firewall is not well thought trough yet.
     
  6. macrumors regular

    jeffzoom91

    Joined:
    Jul 25, 2005
    Location:
    Florida
    #6
    Skype is in my "allow all connections" list in the firewall, but it does the same thing. This is annoying, because, it was my only way to video chat, and Ichat does not work (video chatting wise) with anyone, on any OS at all.
     
  7. macrumors newbie

    Joined:
    Nov 18, 2007
    #7
    My Mac will not accept skype!

    Hi, I have tried your suggestion about deleting all of skype, then turning my firewall off, then reinstalling skype, then turning my firewall on. But the same thing always happens. The icon bounces in the dock once or twice, then nothing. Any suggestions??
     
  8. macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #8
    Remove Skype, download Skype again, copy the application to Applications (or wherever you put it), immediately (without running Skype) right-click on Skype and select "Get Info", then check "Locked".

    Or run Skype from the DMG instead of copying it to Applications first. Might work too. I use the first way, though. Works great with the firewall on.
     
  9. macrumors newbie

    Joined:
    Nov 18, 2007
    #9
    "Remove Skype, download Skype again, copy the application to Applications (or wherever you put it), immediately (without running Skype) right-click on Skype and select "Get Info", then check "Locked".

    Or run Skype from the DMG instead of copying it to Applications first. Might work too. I use the first way, though. Works great with the firewall on."

    thank you for your suggestions. i followed your first suggestion, but the 'locked' option is greyed out and not available for me to select it. any ideas?
     
  10. macrumors newbie

    Joined:
    Dec 14, 2007
    #10
    Hi,

    I also have this issue with yahoo messenger and skype, any help É
     
  11. macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #11
    If you did the update ... you should try a fresh install.
     
  12. macrumors newbie

    Joined:
    Dec 14, 2007
    #12
    Thanks,

    Being at firewall windows ( I have an Imac G5 not intel) it seams like yahoo and skype are not on the list of the services. Should I add them? I have tried to add yahoo messenger with this port number but didn t work.

    Any help on that!

    Thanks!
     
  13. macrumors newbie

    Joined:
    Dec 14, 2007
    #13
    sorry, the port number is 5100 for yahoo, I found it in the internet but don't know if it's correct!!
     
  14. macrumors regular

    nemex

    Joined:
    Nov 14, 2007
    Location:
    Mexico
    #14
    I am using Skype without problems in Leopard, a few days ago Skype released a new build to address problems with 10.5.x

    http://share.skype.com/sites/mac/

    I am using the beta version and so far so good :apple:
     
  15. macrumors newbie

    Joined:
    Dec 14, 2007
    #15
    skype problem resolved

    I have tried the following steps and it works!


    Repair disk permissions using Disk Utility.

    Complete all the updates from Mac OS X Software Update (especially Quicktime).
     
  16. macrumors 6502a

    nsbio

    Joined:
    Aug 8, 2006
    Location:
    NC
    #16
    Also, get the latest version of Skype. I think it is 2.7.0.195 BETA by now, and it specifically addresses Leopard's firewall issue. Works well for me. Plus, ever since 2.7 beta, one could send multiple files at once (and even entire folders) and (at last!!!) Skype finally allows you auto accept files.
     
  17. macrumors newbie

    Joined:
    Apr 18, 2015
    #17
    Mac Says Skype Cant Be Opened

    So I went on Skype.com and downloaded it for mac and it told me what to do. So i downloaded it dragged it to applications and i clicked it. But when it opened it said installerS needs to be allowed then it said Skype can't be opened.
     
  18. macrumors newbie

    Joined:
    May 21, 2015
    #18
    Skype won't open

    Someone's got to solve the problem? I do the same things - downloaded from the official site, but I can not open
     

Share This Page