SL cursor moves automatically to button

Discussion in 'OS X' started by peckerhead, Aug 31, 2009.

  1. macrumors member

    peckerhead

    Joined:
    Apr 26, 2009
    #1
    Apologies if this has been discussed before as i haven't seen it.



    When I try to run an app which requires Rosetta, the install Rosetta dialog box appears which is fine.

    However, the cursor automatically actually moves to the dialog box and positions itself right above the Install button. It doesn't actually click it but it kinda freaked me out to see it happen.

    Has anyone else seen this happen? Does it happen on any other dialog boxes?
     
  2. thread starter macrumors member

    peckerhead

    Joined:
    Apr 26, 2009
    #2
    After playing with Snow Leopard for a few hours, this behaviour does seem to occur in other apps too.

    Most of the time it is not too bad, but in Filezilla the cursor seems to move to the 'Quickconnect' button, even if you have already connected using the site manager.

    And in Office 2008 when closing an unsaved file, the cursor automatically moves to the save button which makes me concerned that it will be easier to accidentally overwrite changes that I didn't want to.

    Does anyone know how to disable this behaviour in snow leopard?
     
  3. thread starter macrumors member

    peckerhead

    Joined:
    Apr 26, 2009
    #3
    OK, i have managed to fix the issue and here is the answer just in case anyone else is experiencing it.

    It is actually a 'feature' and was caused by the following box being enabled in the Universal Access settings.

    I did an upgrade from Leopard and didn't have this issue in Leopard so not sure why it started happening, but all is now well again :)
     

    Attached Files:

  4. macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #4
    I use TextExpander which requires "Universal Access" to be enabled.

    Anyone know how to stop the automatic cursor move with "Universal Access" enabled?

    S-
     
  5. macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #5
    On my system at least, I found out how to turn this off and it has nothing to do with the "Universal Access" system preferences item. It was SteerMouse and its "Automatic Moving" option unders "Cursors" settings.

    I am not sure why this never happened until I enabled "access for assistive devices". But no matter....

    S-
     
  6. thread starter macrumors member

    peckerhead

    Joined:
    Apr 26, 2009
    #6
    Thanks, I have Steermouse installed too. Didn't think to look in there.
     
  7. macrumors newbie

    Joined:
    Sep 14, 2009
    #7
    Automatic moving cursor

    I wanted Automatic Moving of the cursor but couldn't figure out why it was not available for selection in SteerMouse preferences. So thanks guys for pointing out that it's controlled by the "Enable access for assistive devices" checkbox.
     
  8. macrumors newbie

    Joined:
    Feb 18, 2009
    #8
    Thanks @sidewinder! I needed "enabled access for assisted devices" enabled, but the cursor moving was driving me crazy! I too have Steermouse installed too, and that took care of it. Weird that Universal Access would re-enable that option in Steermouse, but, thanks for the post! Saved me a bunch of headache! :)
     

Share This Page