Sleep Image after 2.0 update

Discussion in 'MacBook Air' started by SWPROX, Nov 9, 2012.

  1. macrumors member

    Joined:
    Oct 19, 2012
    Location:
    Vancouver,Canada
    #1
    I have a mid 2012 MBA 13",and I just updated it to 2.0 update yesterday,the problem is now eveytime I reboot,the sleep image comes back :confused:,I had originally deleted that 8GB file,and set the mode to 0,now even though I have set it to 0,I delete the file and it comes back again,I have searched and found a few people experiencing the same issue-any clue guys ?
     
  2. mag01, Nov 9, 2012
    Last edited: Nov 9, 2012

    macrumors member

    Joined:
    Apr 10, 2011
    #2
    So far there seems to be no way to get rid of it, however there are some more or less acceptable ways to prevent that huge file from being created.
    1. creating a zero size sleepimage file and making it immutable: https://discussions.apple.com/thread/4492672?tstart=0
    2. redirecting the sleepimage to /dev/null: http://www.laszlopusztai.net/2012/11/09/hibernate-file-issue-with-macbook-2012-update/ or http://forums.macrumors.com/showpost.php?p=16264456&postcount=84
    I like the 1st option more but whatever...
     
  3. macrumors newbie

    Joined:
    Nov 9, 2012
    #3
    Hey ! I am the author of the discussions on Apple website. I don't know why there is a mess with the update 2.0 and the sleepimage but I'm glad to see that my post is useful :D
     
  4. macrumors member

    Joined:
    Apr 10, 2011
    #4
    garbor: just one minor glitch in your last command, it should be:
    Code:
    chflags uchg /private/var/vm/sleepimage
     
  5. thread starter macrumors member

    Joined:
    Oct 19, 2012
    Location:
    Vancouver,Canada
    #5
    Hey Guys Thanks a LOT !! But just one thing,when I wrote the command chflags uchg/..... it gave me an error-permission denied,then I wrote sudo before chflags and it worked :D,thanks :)
     
  6. macrumors newbie

    Joined:
    Nov 9, 2012
    #6
    Actually I did this in root user so I didn't need to add sudo before my commands and take off the '-' of course (bad habit with Linux ^^). But yes don't forget to add sudo before typing your commands if you don't have rights :D
     

Share This Page