Slow boot caused by "Waiting for DSMOS"

Discussion in 'OS X' started by kosty, Oct 5, 2010.

  1. macrumors newbie

    Joined:
    Oct 5, 2010
    #1
    Since the update from 10.6.3 to 10.6.4 my macbook pro 13" 2009 (now 2010 modell since today) hangs on the boot process for 8-10 seconds.
    After checking with Verbose Mode and the kernel.log I found that the mac is "Waiting for DSMOS" and takes that long until "DSMOS has arrived".
    Updating to 10.6.5 Beta didn't help.

    After some research I found out that DSMOS (Don't Steal Mac OS X.kext located in System/Library/Extensions/ is responsible for AES Decryption and is preventing OS X to be installed on non-Apple Hardware.

    I don't understand why checking this Kext takes so long on a genuine Macintosh.

    I can see the same issue on my Macbook Pro 2009 and 2 Macbook Pro 2010.

    I tried the following:

    - Set Macintosh HD as my startup drive
    - Check Harddrive with Diskutility
    - Repaired Permissions
    - PRAM + NVRAM Reset
    - SMC Reset
    - Safe Mode
    - Verbose Mode
    - deleted and restored Kernel + Boot Cache
    - 32bit Kernel + 64bit Kernel Boot

    Does someone have the same problem ?
    My Macbook is booting so slow now even with my SSD.

    You can double-check your system by booting into Verbose Mode (hold cmd+V after the startup Chime until you see text scrolling) or you can simply check kernel.log in console.app.

    I have attached a screenshot of my kernel.log

    I hope someone can help me with this issue.
    Thanks
     

    Attached Files:

  2. LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Here's what I see on my Core Duo iMac4,1 running OS X 10.6.4:

    Code:
    Oct 10 11:12:32 Magpie kernel[0]: Waiting for DSMOS...
    Oct 10 11:12:34 Magpie kernel[0]: AppleYukon2: Marvell Yukon Gigabit Adapter 88E8053 Singleport Copper SA
    Oct 10 11:12:34 Magpie kernel[0]: AppleYukon2: RxRingSize <= 1024, TxRingSize 256, RX_MAX_LE 1024, TX_MAX_LE 768, ST_MAX_LE 3328
    Oct 10 11:12:44 Magpie kernel[0]: DSMOS has arrived
    So my guess is the delay is "normal", or at least, is not local to just your computers. :)
     
  3. macrumors newbie

    Joined:
    Apr 13, 2010
    #3
    I noticed the extra-long delay at boot after upgrading as well. Mine is taking a whopping 27 seconds before "DSMOS has arrived". :(

    Code:
     Oct 14 19:06:23 localhost kernel[0]: Waiting for DSMOS...
     Oct 14 19:06:24 localhost kernel[0]: systemShutdown false
     Oct 14 19:06:48 ingrid kernel[0]: Previous Shutdown Cause: 5
     Oct 14 19:06:49 ingrid kernel[0]: AGC: 2.8.63, HW version=1.7.3, flags:0, features:4
     Oct 14 19:06:49 ingrid kernel[0]: NVDANV50HAL loaded and registered.
     Oct 14 19:06:49 ingrid kernel[0]: wl0: Broadcom BCM432b 802.11 Wireless Controller
     Oct 14 19:06:49 ingrid kernel[0]: 5.10.91.27
     Oct 14 19:06:50 ingrid kernel[0]: DSMOS has arrived
     
  4. macrumors 6502a

    Joined:
    Sep 16, 2009
    #4
    I sometimes have the same problem, for me it's caused by /. and /.. owner changing to me:mygroup (I have a custom GID to make nfs work at the office).
    I think it changes after a system update. Repair permissions does not fix this. Solution:

    terminal:
    cd /
    sudo chown root:admin /.
     
  5. macrumors newbie

    Joined:
    Apr 13, 2010
    #5
    Wow -- that knocked my 27 seconds down to 5. Thanks for the tip!
     
  6. LPZ
    macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    What did you have for owner and group on /. before you issued the Terminal command?

    Isn't root:admin the default?
     
  7. macrumors 6502a

    Joined:
    Sep 16, 2009
    #7
    NP - took me a while to find that fix ;)

    I have no idea why it happens though, I guess I should file a report with Apple - BTW what are your user settings ('id' command from terminal)?
     
  8. macrumors regular

    Joined:
    Jun 23, 2009
    #8
    I also had trouble with this. My boot time went from 16 secs to 30 secs (X25-M) after the 10.6.5 update. After changing the owner of / back to "root", the problem was solved.
     
  9. macrumors 68000

    Joined:
    Nov 4, 2008
    #9
    What about /.. though?
     

Share This Page