slow launch of iTunes

Discussion in 'Mac Apps and Mac App Store' started by robertmorris2, Mar 7, 2007.

  1. robertmorris2 macrumors newbie

    Joined:
    Mar 15, 2006
    Location:
    Key West
    #1
    has anybody reported slow and somtimes no launch of iTunes after the latest update...? It takes about three minutes for iTunes to launch. No other change in system since or before update.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    iTunes 7 has always been a bit slow. Have you got any iTunes-related peripherals plugged in or are you running your library from an external drive? What area does it seem to be chugging on? Is it stuck at the Loading Library dialogue box? Are you on a Mac? :)
     
  3. dylan macrumors 6502

    Joined:
    Jul 9, 2005
    #3
    I find it loads a lot slower in Cover Flow, but 3 minutes is way too long. I'd try trashing trashing the preferences, app support and cache.
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    If you don't feel comfortable trashing stuff, then create a new user account in System Preferences and check whether the slowness carries over. If it doesn't, then you can narrow the problem down to something in your Home folder. :)
     
  5. synth3tik macrumors 68040

    synth3tik

    Joined:
    Oct 11, 2006
    Location:
    Minneapolis, MN
    #5
    The only issues I have had are with cover flow, and it's not bad just chokes a little. Otherwise my iTunes runs pretty good.
     

Share This Page