Slow Mac App Store

Discussion in 'Mac Apps and Mac App Store' started by Fuith, Nov 28, 2012.

  1. macrumors member

    Joined:
    May 5, 2011
    Location:
    Tralee, Co. Kerry, Ireland
    #1
    Hi guys, my Mac App Store seems to run incredibly slow to load up. It takes over two minutes to load the app and then most of the images (if any at all) just have a question mark (See screen shot below). I've done a bit of googling and I've tried the keychain access trick to no avail. Any ideas?
     

    Attached Files:

  2. macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #2
    Same issue here across 2 macs, different states, and different countries.
     
  3. macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #3
    Just tried it, was a little slow but everything loaded. Have either of you tried creating another user account to see if the MAS is slow/doesn't load under it?
     
  4. macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #4
    Just tried. Same problem. :-/ the downloads are fast in the Mac App Store (it only took me about 2 min to download the 10.8.3 update), it's just the loading of pages that's slow as all get out.
     
  5. macrumors regular

    Joined:
    Jul 15, 2008
    Location:
    Manchester, UK
    #5
    Been having the same problem. Signing out of the App Store and back in again fixed it for me.
     
  6. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    I'm getting this too. Removing the Mac App Store's caches clears it up for a while, then it comes back again. Frustrating.
     
  7. macrumors member

    Joined:
    Feb 23, 2013
    Location:
    East Java, Indonesia
    #7
    I'm not experiencing this issue.

    Macbook pro as listed in my signature, 2Mbps ADSL2, and Time Capsule.
     

Share This Page