Slow Wireless File Transfers

Discussion in 'Mac OS X Server, Xserve, and Networking' started by donnybrassko, Apr 17, 2011.

  1. macrumors newbie

    Joined:
    Apr 17, 2011
    #1
    Hi I'm hoping someone can help me out here. I've got an older Airport Extreme (early 2008) running N standard at 2.4 GHz. I can't set it to 5 GHz because my iPad 2 and iPhone can't connect to that spectrum. File transfers between my computers are extremely slow. For example it takes about 10 minutes to transfer a 550 MB file from my iMac to my MBP. Is there anything I can do to speed up my local network?

    Settings on Airport Extreme:

    Multicast Rate: 24 Mbps
    Transmit Power: 100%
    Ethernet WAN Port: Automatic (When I changed it to 1000 Mbps/Full Duplex, I can't connect to the internet)
     
  2. macrumors 6502a

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #2
    If both of those computers are wireless, the speeds you're experiencing are about right. Try putting one of those computers on Ethernet and watch your transfer speeds more than double. Put them both on Ethernet and expect to see a 10x speed increase.
     
  3. macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #3
    His transfer speed is 0.9MB/s, which isn't normal at all.

    On a 2.4GHz band, I usually get around 7MB/s from wireless to wireless machine using an Airport Express.

    OP, try to move your Extreme around the room to avoid interferences.
     
  4. thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #4
    Thanks Transporteur, I'll give that a shot, though I can't imagine moving the router anywhere else. I'm in a small 1x1 condo and pretty much everything is in my living room. From where I'm at to my router is about 5-7 feet, the same goes for my iMac. I've also tried changing the channels to reduce interference but that doesn't seem like it's helped much if any.
     
  5. macrumors member

    Joined:
    Sep 25, 2009
    Location:
    IL
    #5
    If youre in a condo building there are probably 10 other 2.4ghz APs using your same freq. You could try changing channels. But ultimately, wireless isnt the best option in a crowded area like that. Id say bite the bullet and run ethernet, at least to you imac.

    If you want to have a little fun, you should find a 2.4ghz noise generator. Turn it on for a week. Everyone in your building will get out of your spectrum, then you can have it all to yourself.
     
  6. thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #6
    LOL that would be very fun.:D

    I tired moving my router and that didn't do any good. I guess I'll either have to use ethernet when doing transfers or I'll need to get a new AP that can support 2.4 and 5 simultaneously.. Thanks for the feedback everyone.
     
  7. macrumors 6502a

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #7
    Impressive. I get nowhere near 7MB per second unless one of the computers is on Ethernet. This is sitting in the same room as the base station on my first-generation Mac Book Pro with wireless-N card installed.
     
  8. macrumors 6502

    mainstay

    Joined:
    Feb 14, 2011
    Location:
    BC
    #8
    I had historically transferred (in a 1600 square foot house with minimal interference) at about 1-3 MB/s with and AEBS and a TC (draft-N). I tried many times to figure out why I was unable to achieve these oft touted 300Mbs for draft-N.

    Turns out, ONE of my wireless units was set to operate at 20/40 MHZ. When I switched it to 20 MHZ ONLY my speeds tripled and I am getting a much more reliable 12MB/s (big B).
     

Share This Page