1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Slow wireless internet on PowerBook

Discussion in 'PowerPC Macs' started by GregUofMN, Apr 28, 2008.

  1. macrumors regular

    #1
    Hi All--

    I just got a new MacBook Pro, but my wife uses my old 1.25GHz Alum. PowerBook. My MB pro flys, but unfortunetely, the wireless ethernet on my old PB is slow as hell.

    I've got 11+GB of free space left on my hard drive and Safari or Firefox are the only applications I have open. I also have a cable internet connection with wireless through my 1st Gen Airport Express, yet it's still slow.

    Any ideas on how to speed things up? THANKS!
     
  2. macrumors regular

    #2
    bump
     
  3. macrumors 6502a

    im_to_hyper

    #3
    When you say slow, are you talking about internet browsing or file transfers?
     
  4. macrumors regular

    #4
    Both.
     
  5. macrumors 6502a

    im_to_hyper

    #5
    Are you using Tiger or Leopard on it? If Leopard, did you have these problems before upgrading? If Leopard, are you up to date with all your updates?

    Also, what version firmware is your Airport router? I've heard of people needing to downgrade to the next oldest firmware... otherwise if you aren't up to date an upgrade could help.

    To Check:

    Open up the AirPort Admin Utility in Applications --> Utilities
    In the left side, click your router, then the FW version should show up on the right side.

    Additionally, have you tried unplugging it and plugging it back it?

    Do you have any encryption? If so, try disabling it and see if that helps at all. If you are using WPA, I've personally found on Linksys routers that WEP makes connection speeds much, much faster.

    If none of this works, try the following:

    Go to the base station as mentioned above in the utility, then click on Base Station Options, WAN Ethernet Port, and you will see a box about like remote configuration or something. Disable this. Be sure to save the settings.

    If you are still having problems... is there a microwave near by? Any cordless phones near the router? If none of the above worked, try turning on Interference Robustness (in Tiger. In Leopard... IDK actually)

    There are probably more things to do with kexts and such if this fails, but that is all beyond me.

    EDIT: Apple discussion board thread I just found on this topic...
     

Share This Page