Slow wireless

Discussion in 'MacBook Pro' started by aussie.damo, Dec 2, 2006.

  1. aussie.damo macrumors regular

    Joined:
    Nov 20, 2006
    Location:
    Melbourne
    #1
    Hi all,

    Sorry if this has been asked already, but I can't seem to find the answer. I've got my new MBP C2D (15") and am having some trouble with the wireless. It connects no problem, but file downloads are SLOOWWW. I have cable internet, attached to a D-Link 614 wireless router.

    The speed is great on my old windows laptop. I've tried downloading files with Safari and Firefox, same result.

    Is there some setting I might need to change? Is there maybe a power saving that I haven't noticed?

    Thanks in advance.

    Damo
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    What sort of security do you have on the wireless network? Are you getting good reception? :)
     
  3. aussie.damo thread starter macrumors regular

    Joined:
    Nov 20, 2006
    Location:
    Melbourne
    #3
    I've got WEP encryption on. Signal strength is fine, i'm about 3 metres from the AP, direct line of sight. The AirPort indicator has all bars lit up (I assume they disappear as signal strength weakens?)

    I am going to get a new AP at some point as the WPA support on the D-Link I have is woeful. Just wanna make sure I haven't missed some special config I need to do on the Mac to make wirless "go fast" :eek:

    Man, I hate bein a noob!

    Damo
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Mate, disable the security for a while and see if it's faster. This might help us determine if it's a problem with the WEP configuration. :)
     
  5. adiosk8 macrumors regular

    Joined:
    Oct 20, 2006
    #5
    You should never use WEP encryption anyways, if you can change to WPA or see if there is a firmware update for your router that supports WPA...you can crack WEP in 15 mins
     
  6. aaron.lee2006 macrumors 65816

    aaron.lee2006

    Joined:
    Feb 23, 2006
    Location:
    Ontario, Canada
    #6
    IT IS YOUR ROUTER. I have a D-Link 614+ and the wireless isn't slow. It just isn't responsive all the time. Get a new router. We have the same one doing the same problem. You will start to notice how great the reception is when you are on different routers!!!:D
     
  7. aussie.damo thread starter macrumors regular

    Joined:
    Nov 20, 2006
    Location:
    Melbourne
    #7
    Okay, thanks for the tip. I want to replace my router ASAP, have been waiting for my cable provider to drop their "heartbeat" requirement, then i'll get a Linksys or something.

    It is strange that it only happens on the MBP though. I have a number of other latptops (HP & Toshiba) and they all work really well!

    Thanks for the help guys.

    Damo
     
  8. aaron.lee2006 macrumors 65816

    aaron.lee2006

    Joined:
    Feb 23, 2006
    Location:
    Ontario, Canada
    #8
    I know what you mean all my PC towers worked fine with the router. But I just run ethernet when at home now. My parents use the wireless.
     
  9. aussie.damo thread starter macrumors regular

    Joined:
    Nov 20, 2006
    Location:
    Melbourne
    #9
    Fixed!

    Hello all,

    Looks like this problem has been resolved. A bit more investigation after the advice I got here led me to a thread on the apple site It's kinda long, so here's the relevant bit:

    "A few notes on what has helped my connection. I have a DI 614. Under the Advanced tab: Disable 4x mode. Set Preamble Type to Long. Set the basic and TX rates to 1-2-5.5-11. Lastly, per advice earlier in the thread, I set the Beacon interval to 50."


    The difference was instantaneous! Anyone with this router should look at using these settings.

    YAY!
     
  10. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #10
    Very good find. Of course, I just went and got myself a Linksys when my mini wasn't connecting..
     
  11. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #11
    This tip worked for me to. I didn't want to replace my router as its been soooooooooooo reliable for me. Been using it for close to 4 years now. The super G router (634M or something) i bought to 'replace' has been so unreliable that i've decided to bin it and stick to what works.
     
  12. mannix87 macrumors 6502

    Joined:
    Nov 16, 2005
    Location:
    in the southeast
    #12
    I use a Linksys at home and it works perfectly. fast downloads and all. but when I'm in the office, we use Netgear, w/c sucks a bit. whenever I turn on my MB, the wi-fi can't connect, the router has to be reset 1st before the MB can go on-line.
     
  13. aaron.lee2006 macrumors 65816

    aaron.lee2006

    Joined:
    Feb 23, 2006
    Location:
    Ontario, Canada
    #13
    YOU ARE MY HERO!!! lmao I'll give this a shot tomorrow when I get around to it. I'm sick of my games always disconnecting. OH and by the way if you use your wirelss under XP on your mac it will work perfectly! Strange but i guess that's the way things go lol. Thanks for the find though!
     

Share This Page