Smart Albums Not Working In iPhoto?

Discussion in 'Mac Apps and Mac App Store' started by todd2000, Dec 27, 2006.

  1. todd2000 macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
    #1
    It seems my smart albums are messed up, I have pictures that clearly match the criteria for the smart album that are not showing up in said album. For Example I have a smart album that is susposed to include any file starting with DSC, and I have files that CLEARLY start with DSC that iPhoto refuses to put in the smart album. Any thoughts? I already deleted the preferences didn't help. Thanks
     
  2. Aniej macrumors 68000

    Aniej

    Joined:
    Oct 17, 2006
    #2
    get rid of the sony haha, just kidding. try dragging a few of these into the smart folder and then run it again; make a new smart folder. Wort case scenario, change the settings on the cam so they do not put the dsc out as the file name. go into menu on the camera. also try not using caps
     
  3. todd2000 thread starter macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
    #3
    Well It wasn't the DSC that was the problem I tried it with HPIM from my old HP camera, and it didn't find all of the photos either. I don't really know what the problem was, but I deleted my library folder, and re-imported from a backup, and it seems to be working now, must have had a bad config file or something.

    And BTW you can't drag files onto smart albums
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  5. todd2000 thread starter macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
    #6
  6. todd2000 thread starter macrumors 68000

    Joined:
    Nov 14, 2005
    Location:
    Danville, VA
    #7
    EDIT: Well I though it was fixed, but I just imported 100 new photos from my camera, that all start with DSC, and it didn't add them to the DSC Smart Album. Im soo confused, I shouldd have to re-build my library everytime I import pictures should I? I even set up another user account with the same iPhoto library, and tried it in that account and it didn't work either.

    UPDATE: I searched around and apparently it's a known bug with iPhoto 6, that smart albums dont always update automatically, I guess I'll have to make my Albums manually and wait for an update that addresses the issue.
     

Share This Page