iPhone SMS won't switch to iMessage anymore.

Discussion in 'iOS 6' started by KidSqueek, Nov 16, 2012.

  1. macrumors newbie

    KidSqueek

    Joined:
    Nov 16, 2012
    #1
    I've been having this problem since upgrading to iOS 6 on my iPhone 4s. When I compose a new text message to someone with an iPhone with iMessage activated, it doesn't switch to iMessage automatically and sent it as a text message but when they reply, it's in iMessage. I'm assuming there is something wrong on my end. It happens all the time when I compose a new message to other iMessage users. My settings seem fine. Anyone else experiencing this issue? :confused:
     
  2. macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #2
    Hmm try turning off the "use SMS when iMessage is unavailable" setting. It's under the iMessage settings.
     
  3. thread starter macrumors newbie

    KidSqueek

    Joined:
    Nov 16, 2012
    #3
    Thanks! That actually helped. I also added my email address too. It's working fine now. Maybe I've had it off before and never noticed. I may have turned it on by accident when messing with the settings a while back.
     

Share This Page