Snow Leopard - can't authenticate

Discussion in 'OS X' started by szhrmp, Aug 28, 2009.

  1. macrumors newbie

    Joined:
    Feb 27, 2009
    Messages:
    8
    #1
    Just upgraded to Snow leopard. Logged in into my normal user account - I cannot become admin anymore (e.g. click on the authentication lock in system preferences). The authentication window appears and then immediately disappears !

    Changing this account to admin doesnt solve the problem - now when I click the lock no dialog appears. very annoying.
     
  2. macrumors newbie

    Joined:
    Aug 28, 2009
    Messages:
    2
    #2
    Snow Leopard - can't authenticate!

    Me too!

    However, I was so lucky to have 2 admin accounts active in my user folder. I logged out of my home directory and logged into the other user account. Authentication worked fine on that account!

    I was able to create new admin accounts that also worked fine vis a vis authentication.

    Since most of my documents are in my main account, I tried to delete it and leave the home folder untouched, then reset the new account to the old "deleted" user home directory. The newly created account also could not authenticate. There must be some file in Library or a hidden file in Home that is preventing the authentication process.

    If I try to delete a file in the Applications folder, I get the following error:

    The operation can’t be completed because an unexpected error occurred (error code -60008).

    I could do an install and replace, but that probably will drag the offending file back in.
     
  3. macrumors newbie

    Joined:
    Feb 27, 2009
    Messages:
    8
    #3
    I actually figured out how to solve the problem, the error I was getting is the following (log /private/var/log/secure.log)

    Aug 28 19:53:58 com.apple.SecurityServer[40]: Engine::authorize: Rule::evaluate returned 4294907288 returning errAuthorizationInternal


    turns out that some old files in my users folder in Library/Preferences cause the issue. I removed all and everything works fine (this will remove your settings). I actually think that you might get away by just removing the folder Library/Preferences/ByHost and not the rest of the settings (logout is required).
     
  4. macrumors newbie

    Joined:
    Aug 28, 2009
    Messages:
    2
    #4
    Authentication

    Yes! Trashing the files in Library/Preferences/ByHost/*.* resolved my issue, too!
     
  5. macrumors newbie

    Joined:
    Aug 29, 2009
    Messages:
    1
    Location:
    USA
    #5
    Solved my problem too! Couldn't authenticate, so I couldn't install anything, change settings....very annoying... Thanks szhrmp!
     
  6. macrumors newbie

    Joined:
    Sep 1, 2009
    Messages:
    2
    #6
    Doen't work!

    Hey Guys,

    I don't have the folder ByHost, and I've tried to delete all but for several folders and files \Preferences\SystemConfiguration and \Pref.\Audio I can't delete because it gives an error. I continue with the authentication problem, any thoughts?

    Thanks.
     
  7. macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Messages:
    3,564
    Location:
    Seattle
    #7
    You are in the wrong Preferences folder.

    /Library/Preferences is in the root of the drive
    ~/Library/Preferences is in your User folder

    No one here really used the correct convention, that might be why you were in the other Preferences folder.
     
  8. macrumors newbie

    Joined:
    Sep 1, 2009
    Messages:
    2
    #8
    Ohh Yesss!

    Wrong preferences, I'm just delete ByHost and it worked.

    Thank you Calderone!
     
  9. macrumors newbie

    Joined:
    Mar 15, 2007
    Messages:
    1
    Location:
    colorado
    #9
    I have same issue and unfortunately this fix didn't work for me :(
    Called applecare & missed them by 1 frickin minute
     
  10. macrumors 6502

    5DollaFootlong

    Joined:
    Apr 26, 2009
    Messages:
    291
    #10
    i seem to have the same problem as you when i try to delete or rename applications, but i'm afraid of deleting the byhost folder as i'm not sure of its effects on leopard.
     
  11. macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Messages:
    3,564
    Location:
    Seattle
    #11
    There is no effect on Leopard. You merely lose any preferences that are set "ByHost." They get recreated automatically with default settings.
     
  12. macrumors newbie

    Joined:
    Jun 28, 2009
    Messages:
    3
    #12
    dudes, I love you. Seriously.

    I'll keep using Snow Leopard :S

    Thanks.
     
  13. macrumors regular

    Joined:
    Jan 1, 2003
    Messages:
    163
    Location:
    California
    #13
    Damn. :( It didn't work for me. I deleted all my preferences and still nothing. I need to install a program but can't because the authenticate dialog won't show up. This is frustrating. :mad:
     
  14. macrumors newbie

    Joined:
    Sep 12, 2009
    Messages:
    1
    #14
    Thanks

    Worked like a charm - and I certainly never would've thought of it. iTunes 9 and the 10.6.1 upgrade finally installed. Thanks!
     
  15. macrumors newbie

    Joined:
    Sep 13, 2009
    Messages:
    1
    #15
    My problem was actually...

    I had the same problem. This solution works for me too, but if I change my keyboard layout back to custom (to one I created with 10.5.4), the problem is reproduced. Neat. I have no idea how that can affect to authentication.

    Cheers,
    Christian
     
  16. macrumors newbie

    Joined:
    Nov 14, 2007
    Messages:
    8
    #16
    Thanks a lot ... I was ready to reinstall Leopard and then Snow Leopard. This issue just bothers, since the solution appears so obscure. In any case, thanks.
     
  17. macrumors newbie

    Joined:
    Sep 25, 2009
    Messages:
    1
    #17
    Worked for me Too !!! Thanks

    1) On Finder, Go to you HD
    2) Choose Users folder
    3) Then, "your user account name" folder (the one that looks like a house)
    4) Select Library
    5) Preferences
    6) ByHost
    7) delete all files inside

    8) Empty trash
    9) Restart Computer

    Now you can acess your Account and Admin account too.

    Worked very fine for me!

    Thanx a lot.


    #from Brazil#
     
  18. macrumors newbie

    Joined:
    Oct 4, 2009
    Messages:
    1
    Location:
    são paulo, brazil
    #18
    this is great. worked for me as well. I was about to reinstall snow...

     
  19. macrumors newbie

    Joined:
    Oct 24, 2009
    Messages:
    1
    #19
    Updates still not working!!

    I followed the directions above, was able to install the Snow Leopard update, but the other updates won't install. BTW, other install packages don't work either....
    Need help Please
     
  20. macrumors newbie

    Joined:
    Dec 7, 2009
    Messages:
    1
    #20
    I deleted all my preferences and it didn't fix my problems. I found this thread:
    http://discussions.apple.com/thread.jspa?threadID=2133327&start=0&tstart=0

    It suggests deleting ~/Library/Fonts/LastResort.dfont

    Same as this post the dialog that appeared after I clicked authenticate didn't look right but at least it meant that I could authenticate the updates. The good news is that once I restarted after the 10.6.2 install all font issues were resolved including the dialog box and I'm a happy bunny again.
     
  21. macrumors newbie

    Joined:
    May 9, 2010
    Messages:
    1
    #21
    Thanks

    Deleting the "By Host" folder worked for me.
    I installed 10.6.0 and it happened to me, would get the prompt to authenticate when installing 10.6.3 update.

    Nice to learn something new.
    Thanks!
     

Share This Page