Snow Leopard Firewall: PS3 Media Server

Discussion in 'OS X' started by groundstrike, Aug 28, 2009.

  1. macrumors newbie

    Joined:
    Nov 9, 2006
    #1
    When I start PS3 Media Server I see the "Allow, Deny" Incoming Connections box pop up for a fraction of a second and then disappear...never giving me the chance. Even moving to the Beta version this didn't work. I couldn't get it to see my PS3 on the network even though PS3 Media Server is listed to allow connections under the Firewall.

    I turn off the firewall and it all works great. So I am thinking that the problem is getting the Firewall settings to be saved (even though it's always listed as allow incoming) or that the Java networking engine is a separate rule that needs to be allowed. Comments? Advice?

    Thanks :)

    edit: made more concise
     
  2. macrumors newbie

    Joined:
    Aug 29, 2009
    #2
    I've got the same problem, but haven't figured out how to fix it yet.
    Edit: also figures out turning off the firewall would do the trick, but that's not a longterm solution.
     
  3. thread starter macrumors newbie

    Joined:
    Nov 9, 2006
    #3
    Sorry, by "fixed tl'dr" I meant that I made the post more concise. However, here is my progress so far.

    Turning off the Firewall: Works perfect, but I want the firewall on!
    Adding PS3 Media Server to the Firewall allow: Does not work.
    Also added java to the firewall allow: Does not work.

    I dont see a way to add anything else pertinent through the Firewall interface. I am pretty sure that the problem is this new Firewall requires very precise instructions as to what is allowed.

    I am going to look at alternatives like configuring ipfw with WaterRoof or NoobProof, but their support under 10.6 is uncertain.
     
  4. macrumors newbie

    Joined:
    Aug 29, 2009
    #4
    They are looking at in over here as well: http://ps3mediaserver.org/forum/vie...id=cc57c2c7e342f8936f18e74dd2c23fba&start=250
    Seems Java related, but I'm no technie.
     
  5. macrumors regular

    Joined:
    Mar 30, 2009
    #5
    The same thing happened to me too.
    I had to restart my macbook holding the shift key pressed in order to be able to see the ps3 in "ps3 media server"
    After playing with it for a while i realized that i have to force the ip of the server in the config tab and it's working fine now.
    Let me know if this helps
    good luck
     
  6. macrumors newbie

    Joined:
    Aug 24, 2009
    #6
    works fine..

    Mine works perfectly with SL and PS3 Media Server. I have a Macbook Pro (3,1). Try to give a static IP and enable port fowarding on your airport.
     
  7. thread starter macrumors newbie

    Joined:
    Nov 9, 2006
    #7
    Force it to what? The same IP as your Machine? The IP of the PS3? An IP totally different from any of those?

    Everything is static on my network. Port Forwarding is for connections outside of your network; everything I'm doing is behind the router.

    The connection is blocked at the OS X Firewall:

    8/30/09 5:05:31 PM Firewall[558] Deny JavaApplicationS connecting from 10.10.1.5:55792 to port 5001 proto=6
     
  8. macrumors regular

    Joined:
    Mar 30, 2009
    #8
    i used the computer's ip address

    ever since then works perfectly
    let me know if it works for you
     
  9. macrumors 6502

    Joined:
    Sep 1, 2007
    Location:
    Alberta, Canada
    #9
    what application, or utility are you guys using to enable the streaming of content to your ps3 console?
    thanks guys in advance
     
  10. thread starter macrumors newbie

    Joined:
    Nov 9, 2006
    #10
    No luck, thanks though. Another interesting thing I've found is that I get the quick flash of an "Allow, Deny" firewall dialog when I open Java Preferences from Utilities.

    http://code.google.com/p/ps3mediaserver/
     
  11. macrumors newbie

    Joined:
    Sep 4, 2009
    #11
    This seemed to work for me:

    1. Turned off the server
    2. Turned off the firewall
    3. Turned the server back on (PS3 detected)
    4. Turned the firewall back on (The Allow,Deny selection came up as soon as I enabled the firewall and stayed on the screen long enough to make the Allow selection)
     
  12. macrumors newbie

    Joined:
    Aug 29, 2009
    #12
    Fixed!

    The way to get PS media server to work as before on Snow Leopard: Rosetta, 32 bit.

    Instructions:
    Open Finder
    Right-click on ps3 media server.app
    Select Get Info
    In the General tab, tick "Open in 32-bit mode" and then tick "Open using Rosetta"

    This way, there's is no need to turn off the firewall or force any IP-adress.
     
  13. Moderator emeritus

    Hellhammer

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #13
    THANKS!!! This fixed it for me at least. Should it be same performance wise because I use it with 1080p .mkv files? Thanks again, you saved my day :p
     

Share This Page