Snow Leopard: Sudo root not accepting the password I set.

Discussion in 'OS X' started by runebinder, Sep 11, 2009.

  1. macrumors 6502a

    runebinder

    Joined:
    Apr 2, 2009
    Location:
    Nottingham, UK
    #1
    Ok so opened Directory Utility, unlocked it and then selected Enable Root User and set a password, locked Directory Utility opened terminal and typed sudo root.

    When I entered the password I set I just get "Sorry, try again". Have tried going back into Directory Utility and changing the password but get the same thing, any ideas?
     
  2. macrumors 65816

    gilkisson

    #2
    If you are meaning to be root in a Terminal, don't do "sudo root". Do "su -" and enter the password.
     
  3. macrumors 6502a

    electroshock

    Joined:
    Sep 7, 2009
    #3
    You don't need to enable the root user. All you need to do is run Terminal.app then do:

    $ sudo -s

    ...and enter your password.

    If that doesn't work, is the user account you're using an administrative account?
     
  4. macrumors member

    Joined:
    Nov 19, 2007
    #4
    Even better, don't enable root user, just type

    sudo su
     
  5. macrumors newbie

    Joined:
    Jan 20, 2013
    #5
    Same problem here

    None of these solutions have worked for me.
    I'm trying to install rails and i need sudo access.
    the command is:
    sudo gem install rails
    When prompted for the password I get: "Sorry, try again"

    I have enabled the root user through CoreServices.

    I've tried:
    sudo su
    sudo -s

    I believe that my user account had admin rights. It says "admin" under the account name in Users. Besides, if it didn't I'd expect to see some kind of permissions error when enabling or changing the root account password.

    Any help is appreciated.
     
  6. macrumors 6502

    Joined:
    May 16, 2011
    Location:
    Orpington, Kent, UK
    #6
    Disable the root account. When it asks you for a password on any sudo or Su command it's asking for YOUR password, not the root password.
     
  7. macrumors newbie

    Joined:
    Jan 20, 2013
  8. macrumors 6502a

    Joined:
    Nov 2, 2008
    #8
    Didn't know that one. I have always done sudo /bin/bash
    then my password.
     

Share This Page