Software Update broken? Mail crashes on launch?

Discussion in 'macOS' started by Max on Macs, May 16, 2006.

  1. Max on Macs macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #1
    Hi guys,

    Since yesterday evening I've noticed too problems with my system. First off when I open Software Update it checks then it doesn't come up with the message saying there are no new updates, it just sits there with no updates showing. I tried rerunning it several times, no luck.

    Then there's Mail.app... Since last night wnenever I open it it just freezes and I have to force quit it. Again, tried reopening it loads of times and no luck.

    It's getting really annoying because I want the new iWeb update. Email isn't too bad at the moment because I can use Mac.com but that's not idea.

    Thanks
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Do these apps work properly in a new user account? :)
     
  3. Max on Macs thread starter macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #3
    Hi there,

    Thanks for the response and sorry for the delay in following it up. I've been so b usy in these last few months I haven't been paying as much attention to my threads here as I really should be.

    I created a new account and ran software update. It worked fine so I logged out and logged into my original account and Software Update worked fine on that one now too. Weird. So then I logged into the new account and opened Mail. It opened the wizard for setting up a mail account, so I'm guessing it's working, but I didn' actually go ahead and setup an account. I deleted the new account and Software Update continues to work, while Mail does not work on this account still (but if I create a new account it seems fine on the new account, just not this one). What should I do to fix this? Very confused as to why it would work on one account and not another.

    Thanks
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Okay, it could be a corrupt attachment in Mail. Can you think when it started freezing? :)
     
  5. Max on Macs thread starter macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #5
    Started freezing on Tuesday night I think. Monday or Tuesday night. Is there any way I can fix this?
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Okay, check for attachments that you got around that time and remove them. :)
     
  7. 2nyRiggz macrumors 603

    2nyRiggz

    Joined:
    Aug 20, 2005
    Location:
    Thank you Jah...I'm so Blessed
    #7
    indeed...when was the last time u repaired permissions?


    Bless
     
  8. Max on Macs thread starter macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #8
    Hi guys,

    Just did repair permissions and that didn't fix the problem. I had about 50 attachments in .Mac but I downloaded then deleted every one of them and still Mail isn't working. Any other ideas?

    Thanks
     
  9. Max on Macs thread starter macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #9
    Ok I accidently clicked a mailto: link in a web page and... Mail started working again! Weird. Thanks for the advice guys.
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    Glad it's all working, but that is the strangest solution I've ever heard. Hopefully, it isn't just a temporary fix. :)
     
  11. Max on Macs thread starter macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #11
    Seems it is a temporary fix. Mail has started freezin again, and clicking a mailto: link doesn't fix it this time, it just opens and freezes as when opened normaly :eek:
     
  12. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #12
    Okay, well which OS are you on? I'd think about manually reinstalling the OS Combo Update. :)
     
  13. Max on Macs thread starter macrumors 6502

    Max on Macs

    Joined:
    Feb 25, 2006
    Location:
    Milton Keynes, UK
    #13
    I'm on 10.4.6 and it randomly started working again this morning! :confused: I'm thinking maybe the 10.4.7 rumored Mail and Safari fixes will help? My Safari randomly freezes sometime when not active, too.
     

Share This Page