[Solve] nVidia and 10.6.4 Graphics Performance - Read This !

Discussion in 'Mac Basics and Help' started by Marucins, Sep 8, 2010.

Thread Status:
Not open for further replies.
  1. macrumors member


    Aug 6, 2010
    before: http://forums.macrumors.com/showpost.php?p=10827326&postcount=266


    10.6.4 will severely decrease NVIDIA GPU performance by causing it's three clocks to always run at level 0 low power mode.

    1. Edit the AppleGraphicsPowerManagement.kext/Contents/Info.plist's

    MacPro4,1 section and change
    Vendor10deDevice05e2 to Vendor10deDevice05e3

    The 05e3 part is for a GTX 285,

    see http://dl.dropbox.com/u/6372548/OSX86/info nVidia Device.txt for others.

    This is to allow the GPU to have power management; level 2 high power when stressed, and down clocking to level 0 when not stressed (~10C lower).

    The GPU clock will be at level 0 after sleep and wake, but the shader and memory clocks will temporarily be stuck at level 2.
    However, if load is applied and then reduced, shader and memory will return to level 0.

    2. Other Mac machines

    Delete AppleGraphicsPowerManagement.kext.


    Use the AppleGraphicsPowerManagement.kext from 10.6.0/10.6.2/10.6.3

    Temperatures and clock speeds can be seen with nvclock, and for lower temperatures it's recommended to set fanspeed mode to auto with `nvclock -F auto -f', which needs to be set again after sleep and wake


    Correct settings :

    use OpenGL Extensions: Viewer 3.32
    use Multisample: full (x4)
    use Anisotropy : full (16x)

    [​IMG] [​IMG]
    [​IMG] [​IMG]

    back to the game

    FULL SPEED - SCII 1920x1200 Ultra non lag !!

  2. macrumors 65816

    John Doe 57

    Jan 26, 2008
    Los Angeles, CA
    You already posted this in the thread (Here). No need to make a whole new thread with just an answer, though it is helpful.
Thread Status:
Not open for further replies.

Share This Page