SOLVED! FW800 PowerMac G4 just FREEZING!

Discussion in 'PowerPC Macs' started by MrCheeto, Jan 21, 2010.

  1. macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #1
    The person that brought this to me claims it has been working great until recently. The symptoms I'm seeing seems to correlate with heat.

    You can be enjoying some music and suddenly it skips like a dinged up CD and the mouse cursor and EVERYTHING just stops in frame like a Polaroid.

    This only seems to happen when the computer "warms up" after a while. You see, once it freezes, if you restart it it freezes faster, as though it is over-heating.

    So, all I can tell you is that CPU activity just puts this thing in a coma. I've unplugged ALL internal devices except ONE main hard drive to rule out wattage issues, but wouldn't a shortage of watts just make the computer click OFF?

    Thanks all you that are not so noobish as me.
     
  2. macrumors 6502a

    btbrossard

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #2
    That sucks...

    I'm assuming the fans are working properly and there is not a metric ton of dust inside?

    Can you view the temps of the CPU though iStat or the like?
     
  3. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #3
    I'm shocked!

    iStat sez to me this:

    Started at 180ºc

    Locked up when it ticked over to 236ºc

    What applications were running? System Preferences to start iStat -.-'

    This CAN'T be right! I can place my hand on the CPU heat sink as close to the CPU as I can get and it feels COOL!

    Could the temp sensors have become dislodged or something? That reading just is NOT right.
     
  4. macrumors 6502a

    btbrossard

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #4
    I guess it could be. Although (I'm not sure with this specific model) the sensor is either in the CPU itself or underneath and would be hard to dislodge.

    It could be that the thermal paste and the heatsink have become disconnected from the CPU itself.

    It may be worth some effort to reseat the heatsink onto the CPU and see if that helps (you'll need some thermal paste to apply to the CPU).
     
  5. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #5
    OH MAY GAD! YOU'RE RIGHT!

    That reading would make sense because the heat wouldn't transfer to the sink!!

    Silver paste, where are you!

    BRB y'all!

    I'm shining :D
     
  6. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #6
    Any how-to's?
    :eek:
     
  7. macrumors 6502a

    btbrossard

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #7
    Be very carefull :) .

    iFixit probably has a teardown guide to help point out how to get the heatsink off the board.
     
  8. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #8
    I suppose if I can re-paste a 12" PowerBook G4...

    At any rate, the ethernet hasn't worked in ages on this thing. Is this common and is there something I should check while I'm in there?
     
  9. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #9
    This thing is strangely arrousing, I don't know what it is about milled metal components and tiny shiny devices like this beauty

    [​IMG]

    The heat sink wobbled as soon as I loosened the last screw! The paste is a thing of the past! I'm feeling optimistic!
     
  10. macrumors 6502a

    btbrossard

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #10
    If the ethernet is a hardware problem, there probably isn't much to be done for it. You can always employ the technical tap on the ethernet port itself. Could work...
     
  11. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #11
    Woah woah, slow down with your space talk :p
     
  12. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #12
    Crap in a pita, dead again :(

    The temp steadily rose from startup:

    60ºc

    To 180ºc before lockup.

    Something has gone terribly wrong...I'm soooo suing >8
     
  13. macrumors 6502a

    btbrossard

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #13
    Not good.

    If you can't get your money back, I would employ a larger, more forceful "technical tap" to, depending on how you feel that day:

    A- The offending FW800 PowerMac G4

    B- The person you bought it from

    I suggest the following item in either case :) :
     

    Attached Files:

  14. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #14
    Hi MrCheeto,
    Hold on... 180ºc is not possible with this CPU... It should burn when reached ~100ºc. There is something wrong with iStat or with termistor on CPU daughtercard. Download this: http://www.bresink.de/osx/0TemperatureMonitor/download.html - proper version for your OS. If sensor is OK, reads sure will be true. About 57ºc fans should start spin like jet engine... they are controlled by kext.
     
  15. macrumors 6502a

    btbrossard

    Joined:
    Oct 25, 2008
    Location:
    Chicagoland
    #15
    Would this vintage of mac shut itself off if CPU temps are too high?

    Considering it's locking up, I would think that the temp may be too high (but 180ºc is obviously a faulty reading of some sort). The computer would toaster itself at that level of heat.
     
  16. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #16
    No, usually it will lock up (freeze) or even KP. If it's 1.0 GHz single CPU (as it seems to be), max temp under load should be about 40ºc and surely not exceed 50ºc - with stock fans.

    MrCheeto: old new thermal paste removed and new applied? Heatsink properly screwed? If so, try PRAM and PMU reset. If will not help, it could be: bad CPU, bad logic board, bad PSU or simply bad RAM (if temps will be normal) - i can't tell remotely...
     
  17. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #17
    The temp in iStats ticks away with each second, I could almost swear it was somehow telling the time :p

    OK, I'm installing that software but I'm letting the Mac rest between steps, the readings are climbing quick. HOWEVER, no matter how high it reads, and even AFTER it locks up, the fan is just as quiet and calm as ever. You'd swear it was just chilling like a villain named Dillion this whole time.

    I put on new thermal paste and seated the sink just fine, zero effect. My hands are sooo bloodied over these damn things, first mine now this...it's time for an intervention ><

    Update Pending
     
  18. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #18
    OK, I woke it from its slumber and started Temperature Monitor. It started at 34.4ºc then rose in about 2 minutes to 37.xºc.

    I am running NO other apps and since I repositioned the fan I noticed it immediately trickle back down, it's sitting comfy at 35.6ºc for now.

    By this time I'm sure it would have locked up, I'm going to start an application and see how it handles.
     
  19. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #19
    Before I had the chance to start a single application, it read 36.0ºc and then, lock up =\

    After PMU I spent 7 seconds at 36.6º, then...you guessed it.

    The fans are kicking out some serious air, I can feel it all up against my feeties.

    After PRAM reset. After about 2 minutes at 35.4º I started a tiny Quicktime movie, 2 frames into it, lockup.

    This appears to be similar to a heat issue because it locks up faster each time.

    Is there maybe a short somewhere in the PSU cables?

    As well, somebody mentioned dip switches on the CPU :confused:
     
  20. thread starter macrumors 68030

    MrCheeto

    Joined:
    Nov 2, 2008
    #20
    GUYS!

    I love you but...there is another forum. I know I know! Don't kill me!

    The PowerMac is working PERFECT, and just in time! Randall's on his way now (7am) to pick up his ole beaut'!

    Jeez, I can't believe how much I've come to love the PowerMac G4!!! They're godly! Wonderful! In my past experiences I nearly puked a few times from the sickness inducing puzzling issues that plagued them, and every one I ever repaired crashed after doing so -.-'

    This has given me a whole new outlook and respect for these...these...BEASTS!

    I swear, though, since playing with my MDD I've come to know it as a beast. Breathe's heavy, sways the table when it's chomping on DVD's, and growls when you awake it 0.o

    Oh, and for future reference, this is where I found my solution. I've been playing with his FW800 for over 30 minutes with ZERO hangs, all it took was a zero-disk operation :D

    "Hopefully this thread will help someone in the future with a similar problem.

    - Stevan, Oct. 2003"

    It sure did, Stevan, it sure did ;)
     
  21. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #21
    Nice to see that it's working fine. And solution was so simple and 'low bugdet" ;)
     

Share This Page