[Solved] YouTube player no longer working with Chrome

Discussion in 'Mac Apps and Mac App Store' started by Glumpfner, Apr 23, 2010.

  1. macrumors regular

    Joined:
    Dec 15, 2009
    #1
    Hi there,

    about 3 or 4 days ago while surfing on YouTube I suddenly noticed that I can no longer press anything on the player anymore, no matter where on the flash application I press, it always just pauses the video. Even when I go over the volume control or the play button, they don't highlight in red anymore.

    This is very annoying since I can't control the volume, fast forward, rewind, set higher resolution, click the google ads away... nothing works :( It just pauses the video when I click.

    I emptied the cash of Chrome and restarted my Mac but nothing works.

    I tried Safari and YouTube still works properly there.

    I am using the latest version of Chrome (Beta 5.0.342.9).


    Does anyone have a similar problem?
     
  2. macrumors newbie

    Joined:
    Apr 23, 2010
    #2
    I had the EXACT same issue.

    This is how to resolve it

    Make sure Chrome is closed

    Navigate to Your Home Folder > Library > Application Support > Google

    Delete or rename the "Chrome" folder, this will basically default the application so you will loose your bookmarks within Chrome. But hopefully you have been using Bookmark sync feature.

    Launch Chrome and you should be ok
     
  3. thread starter macrumors regular

    Joined:
    Dec 15, 2009
    #3
    Cheers man, it worked although it's not the best solution to simply reinstall chrome.

    I figured out it also works when you simply delete the preferences file in our Home/Library/Application Support/Google/Chrome/Default


    Unfortunately then all your extensions are f*cked :(

    But at least YoutTube is working again, thanks again :)
     
  4. thread starter macrumors regular

    Joined:
    Dec 15, 2009
    #4
    Just a quick update. Problem solved

    It happened to me 3 more times so far and this is VERY annoying when you can't interact with the Flash Player on YouTube. Anyways, I found a a solution without the need to reinstall Chrome nor delete the preference settings.

    The issue lies with the zoom (not magnifying, but chromes zoom - pinch gesture on MacBooks)! If you zoom (pinch) the website of youtube.com, then you won't be able to interact with the player anymore.
    The easiest way is so zoom out again to the default size. Keep zooming until you notice the buttons are responding again.

    If you can't manage to zoom to the default size, here's how to fix it:

    Open up the preferences file in your Home/Library/Application Support/Google/Chrome/Default folder with TextEdit.app

    Now scroll all the way down in the file and look for something like this:

    Code:
       "profile": {
          "exited_cleanly": true,
          "per_host_zoom_levels": {
             "galerie.designnation.de": 1,
             "prodgame02.lordofultima.com": -1,
             "youtube.com": 1
          }
    Your section will look a bit different since you visited different website.
    Delete the whole line where it says "Youtube.com": 1. Hit save and try again.
    Now your YouTubes Flash Player will work properly again.
     
  5. macrumors newbie

    opticbit

    Joined:
    Jul 1, 2010
    Location:
    USA
    #5
    Delete Pref File worked in one acct not other

    I was having this same problem.

    looked around and found this thread.

    I tested it in my guest account and it fixed it.

    then i went back to my regular account deleted pref file and it had no effect. other than being anoying now that i have to reset my prefs

    I think the responsible file is located in the root or system libs, I'll be hunting a little.
     
  6. macrumors newbie

    Joined:
    Jan 3, 2012
    #6
    Another solution

    I had this same problem--couldn't use controls on youtube videos. I found that the issues extended to all Flash sites.

    After trying some of the approaches on this site, I realized that the issue was an incompatibility with one of my Chrome extensions, ChromeTouch. After disabling it, everything works fine. Removing the pref file effectively disables extensions. That is why some observed a recurrence after awhile when they re-enabled the offending extension.

    I recommended disabling all of your extensions and re-enabling them one at a time until you find the culprit.
     

Share This Page