Some of my apps don't work properly...

Discussion in 'iPod touch' started by UFGators2000, Apr 15, 2009.

  1. macrumors newbie

    Joined:
    Apr 14, 2009
    #1
    I have an 8GB 2nd Gen touch..and just a few minutes ago I turned my ipod on, and went to open the Facebook app, and it came up, blank, but it came up, and then not even 3 seconds later closed itself and went back to the home screen.

    The only apps that don't do this are Safari, Mail, Calendar, Weather, Calculator, and Settings...so it seems like anything downloaded is having this problem of starting up.

    Anyone ever encounter this promblem? If so, what do I do to fix it? Thanks in advance.
     
  2. macrumors member

    Joined:
    Jan 4, 2009
    #2
    just try reseting your ipod and if that dosent work then i have no idea
     
  3. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    What firmware are you on?
     
  4. thread starter macrumors newbie

    Joined:
    Apr 14, 2009
  5. macrumors newbie

    Joined:
    Jul 11, 2008
    #5
    I have recently begun to have this problem. It's really annoying and I don't know what to do!!!!!!!! :mad:
     
  6. macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Another reason this sometimes happens is that for whatever reason the iPod forgets that its authorized by your iTunes account to use those applications. Simple fix should just be to connect to your computer and resync anything purchased, whether an app or a song.
     
  7. macrumors newbie

    Joined:
    Apr 16, 2009
    #7
    my friend has the same problem on his 2nd gen, to fix it he just resyncs but it could be a problem if you arent near your computer when it happens
     

Share This Page