Sometimes messages sent as texts and sometimes iMessages?

Discussion in 'iOS 5 and earlier' started by kat.hayes, Dec 13, 2011.

  1. macrumors 6502

    Joined:
    Oct 10, 2011
    #1
    sometimes I notice it indicates a message sent as text message even though I'm sending to someone else with iOS5. Why does it send my messages as texts and not iMessages? Is there a way to confirm how it is sent? Are the bubble colors different?

    Thanks.
     
  2. macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #2
    http://google.com "iMessage"
     
  3. macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #3
    Wow! Blue = iMessage, green = text, though the previous answer was much better.
     
  4. macrumors G3

    Kilamite

    Joined:
    Mar 20, 2007
    #4
    It will send as a text message when you don't have a data connection, and the other person will receive it as a text message if they don't have a data connection at that moment of time.
     
  5. macrumors regular

    Joined:
    Jul 25, 2011
    #5
    sometimes when it gets sent as a text after using purely imessage, the other person will not get it. this happened to me at least
     
  6. kicko, Dec 13, 2011
    Last edited: Dec 13, 2011

    macrumors 65816

    Joined:
    Aug 26, 2008
    #6
    i have noticed this too, unlike the other non-helpful comments the message does appear blue and sends as imessage, but then what happens is the sending fails for whatever reason and defaults to SMS (green) without warning, even though it was sent as a blue imessage.


    I have verizon so it might be a data/voice at the same time thing. The last time it happened i was updating an app and then replied to a text, it was sent as sms since the app was using the data at the moment. Not a big deal but it would be nice to have a warning before it send as sms in case people have no texting plan at all to avoid .25 or whatever a pop
     
  7. macrumors 6502a

    Joined:
    Aug 11, 2010
    #7
    I notice this happens when the other person happens to be on the other line.
     
  8. macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #8
    You can turn off the feature to send as SMS, it's in the settings.
     
  9. macrumors 65816

    Joined:
    Nov 15, 2011
    Location:
    New Jersey
    #9
    i gotta say bbm is much better than this imessage. i had a storm 2 and everything always worked simple. but its the only thing i miss about a blackberry :p
     
  10. macrumors newbie

    Joined:
    Jul 1, 2010
    #10
    iMessage not working

    I'm on ATT and all my texts to other iOS5 devices are being sent as texts. It doesn't matter if I have the Wifi turned on or off. They were sending fine this morning so I'm not sure what's going on.
     
  11. macrumors G3

    Kilamite

    Joined:
    Mar 20, 2007
    #11
    How is BBM better than this? BBM requires you to have a stupid username/ID and then you have to pass that to all your friends as well as your actual mobile number. Then, when you want to send a message, you have to decide whether you want to do it via BBM or SMS, bearing in mind that for the other person to receive it, they have to be in an area of data reception (3G, WiFi etc).

    iMessage is tied in to your mobile number. Then, when you send a message to anyone, your iPhone knows automatically whether that person can receive an iMessage or not. And the iMessage gets sent as an SMS automatically if there's no data available, and the same applies to the person who receives it - if they have no data available it'll arrive as an SMS - all automatically.

    So tell me again, how is BBM so "simple"? And it always working? Lets not forget the nightmare BlackBerry had with their world outage of BBM..
     
  12. macrumors 65816

    Joined:
    Nov 15, 2011
    Location:
    New Jersey
    #12
    maybe ill respond when you provide one fact of bbm because everything you just said is beyond false lol. that outage didn't affect me so i couldnt care less about that
     
  13. macrumors 65816

    Joined:
    Aug 26, 2008
    #13
    thanks i had forgotten about the setting, but i'm not changing it because its not an issue for me, i still have 250 texts per month
     

Share This Page