Songs under album, not artist

Discussion in 'iPod' started by 07dodge, Jun 10, 2012.

  1. macrumors member

    Joined:
    May 31, 2012
    #1
    So I have a 120Gb iPod Classic from about 2008, works flawlessly. Only issue I have is some artists don't appear under the "Artists" section, but are in the "Albums" section. I don't find music by what album the song is on (I can't remember what song is on which album) so it's all by the artist.

    Anyone know how to remedy this problem?
     
  2. macrumors 65816

    Joined:
    Dec 16, 2010
    #2
    This has to do with the way the songs are tagged in iTunes only way to fix it is go back into iTunes and make sure that the artist names are not in the album info other then that if that don't work files must be corrupt
     
  3. thread starter macrumors member

    Joined:
    May 31, 2012
    #3
    How would I determine files are corrupt?

    As an aside, anyone ever had songs only download half way, maybe a bit more? I have a couple songs loaded on the iPod that cut off early
     
  4. macrumors 65816

    Joined:
    Dec 16, 2010
    #4
    If my suggestion didn't work then you will know they are corrupt and if this is so YOu could try to del eat the songs and reload them. But I suspect that it's a tagging issue. This happens to me sometimes like I might set an album to compilation on accident then it won't show up under that artist but will show up in the compilations. But that's an easy fix like I said. Any other questions let me know
     
  5. thread starter macrumors member

    Joined:
    May 31, 2012
    #5
    I'v gone through almost all of them, and doesn't seem like I have them mislabeled. I'll try to reload them, maybe that's all it is. Thanks!
     

Share This Page