songs wont work on ipod, but works on iphone

Discussion in 'iPod' started by fredtye, Nov 9, 2012.

  1. macrumors newbie

    May 1, 2011
    hello, i have a 6th gen ipod nano.

    when i sync my iphone 5 with my computer, the music works. However, when my nano is synced, the music doesn't play. It skips certain tracks.

    Most of my songs are in AIFF format, 1411kbps. I thought there might be an issue with the bit rate being too high, but some songs with the high bit rate are playable while some aren't. I've been googling for help for the past couple of days, but i dont see any answer.

    please help :(
  2. macrumors 65816


    Dec 5, 2010
    I had a similar issue with some songs playing on an iPod Touch but not on a Classic. This was a bit cumbersome, but I whipped out the CDs and re-encoded the skipping songs and that was that.
  3. macrumors 6502

    Aug 1, 2012
    I had a similar problem some time ago with my iPod Touch where certain mp3's were being skipped. If I recall correctly, all I did was delete the songs from iTunes then re-added them, then synced up to the iPod and they were okay after that.
    I'm pretty sure it was as simple as that. Possibly a corrupt iTunes library issue...???
    But anyway, give that a go, if you haven't done so already that is. :)
  4. thread starter macrumors newbie

    May 1, 2011
    i tried deleting one song, which had that issue, however, it still did not work. Do you think i should try deleting my whole entire library? It will take quite a while, but anything to fix this stupid issue

Share This Page