Speaker static when connecting MBP via HDMI

Discussion in 'Mac Accessories' started by flalaw, Dec 12, 2006.

  1. flalaw macrumors regular

    Joined:
    Aug 11, 2006
    Location:
    United States
    #1
    I'm having this really weird static issue. I've got my MBP connected to a TV via HDMI. I've als got my MBP connected to speakers via the headphone jack. Whenever the HDMI cable is plugged in though, I get static out of my speakers, which goes away when i unplug the HDMI. Any guesses what the problem might be?
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    It's almost certainly a grounding problem. Is the Mac connected to speakers that are physically part of the TV, or to speakers that are separate? The most likely culprit is that your Mac's case is causing cross-interference via ground between the video and audio signals.... But beyond jury-rig types of solutions, I'm not sure what to do.
     
  3. flalaw thread starter macrumors regular

    Joined:
    Aug 11, 2006
    Location:
    United States
    #3
    yea, they're external speakers that are giving me the static. even playing thru tv speakers is okay for me. unless i'm mistaken, hdmi should transfer audio too though, but no audio comes outta my tv speakers. is there any setting that i need to fiddle w/ on my MBP?
     
  4. stillwater macrumors regular

    Joined:
    Sep 1, 2004
    Location:
    Rowley, MA
    #4
    I'm assuming you're using a DVI to HDMI cable or adapter. DVI is video only. You must still send the audio seperately to the TV.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    I have seen this problem when redirecting digital audio from a HDTV to an external amplified speaker. The cure is to select CD as the sound source.
     

Share This Page