spell check doesn't work in Word on my mac

Discussion in 'Mac Basics and Help' started by chasinreveries, Feb 4, 2007.

  1. chasinreveries macrumors newbie

    Joined:
    Sep 28, 2006
    #1
    For some reason spell check does not work on my mac. I have Microsoft Word 2004 and as far as I can see I have the spell check on and it should be functioning correctly. No matter how many words I spell incorrectly, I'll hit Check Spelling, and it'll say that there aren't an errors. I click ok and that's it.

    Anybody have any idea why this could be happening?
     
  2. twofiftyseven macrumors newbie

    Joined:
    Feb 23, 2008
    #2
    I'm having the exact problem... Whenever I click spell check it reads "spell check is complete" when I purposefully have misspelled words. Suggestions?? I only started having this problem when I installed leopard.
     
  3. Hankster macrumors 68020

    Hankster

    Joined:
    Jan 30, 2008
    Location:
    Washington DC
    #3
    Per Mac Office Help:

    • If some text is marked with the Do not check spelling or grammar format, Word skips it during a spelling and grammar check. For example, Word automatically marks fields such as DATE and TIME with the Do not check spelling or grammar format so the spelling and grammar checker won't question them. To locate such text or fields and remove the Do not check spelling or grammar format:
    1. On the Edit menu, click Replace.
    2. In the Find what box, delete any text.
    3. Click the arrow show column browser in the lower left corner of the Find and Replace dialog box, and then click Format.
    4. Click Language, and then select the Do not check spelling or grammar check box.
    5. In the Replace with box, delete any text, and then click Format.
    6. Click Language, and then clear the Do not check spelling or grammar check box.
    7. Click Find Next, and then click Replace
     
  4. jessicasimpson macrumors newbie

    Joined:
    Apr 27, 2010
    #4
    mac office 94 word spell check has never worked

    i have a new macbook and i have had it for about a year in February. spell check has never worked. nor the thesaurus. it is funny because the spell check works in this little box but does not work in word at all. i have tried everything that i can find on the internet and nothing has worked please help me. i am about to selll my freakin mac bc it does not hing but aggravate me.
     
  5. davidtime macrumors newbie

    Joined:
    May 21, 2010
    #5
    This is how I got mine to work

    Go to tools>language> then select Engish, (mine was selected to russian for some reason) Then uncheck the box that says "don't check spelling"
    Worked for me!
     
  6. jokma macrumors newbie

    Joined:
    Jun 21, 2010
    #6
    I have the same problem

    Did you ever get this resolved? I have the same problem and have exhausted all the usual advice....



     
  7. durden macrumors newbie

    Joined:
    May 15, 2010
    #7
    this worked for me

    from: http://forums.macrumors.com/showpost.php?p=5960916&postcount=3

    I finally figured out this method of making the spellcheck work:

    1. Highlight the entire text in the document you want to check.
    2. Click the 'Tools' Option on the menu bar.
    3. In the drop down menu under 'Tools' click Langauge. Then select 'English UK' or 'English US' as appropriate. Click OK. this should result in the red line appearing under spelling mistakes in the document.
    4. Then click the 'Tools' option again and click on 'Spelling and Grammar' in the dropdown menu. You should then see suggestions to correct each spelling mistake (Make sure the cursor is on the word you want to correct before clicking 'spelling and grammar').

    The Autocorrect function seems to be completely useless.

    CN123
     
  8. MotherShabubu macrumors newbie

    Joined:
    Aug 19, 2010
    #8
    Remove .prefs.plist files

    This might be a drastic solution, but it seemed better than re-installing Microsoft Office.

    Find the com.microsoft.Word.prefs.plist and com.microsoft.Office.prefs.plist files and move them to some other folder, so that they won't be there when Word looks for them. On my MacBook with Office 2004, they are in Library/Preferences/Microsoft.

    After you move the Word.prefs.plist file or perhaps both the Word and Office files, open Word again and it will create a new prefs.plist file(s). If you had at some point been able to spell-check, it should work again. For years, spell check had worked beautifully, and then it just stopped one day. I followed every suggestion in intertubespace, and this is the only thing that worked.

    If spell check works, you can delete the old prefs.plist file(s) because the new ones Word created will function just fine now. If this didn't fix the problem, I would move the old prefs.plist files back to where they were and delete the new ones.
     
  9. Leisuregroove macrumors newbie

    Joined:
    Nov 23, 2010
    #9
    Spell check dont work on MAC off 08

    Hi there,

    I dont know if you are still having the same problem with word, I had the same problem, searched and found a solution that works for me, it may do for you..

    First, do you have the book that appears at the bottom of the word page? it usually has some animation whilst your typing indicating its spell checking?

    Assuming that you have this, right click on the book and select "hide spelling errors" (which should be already deselected),and then deselect hide spelling errors. This should now show all the errors..

    Hope this helps..

    Best,

    Trev
     
  10. MPK19 macrumors newbie

    Joined:
    Mar 20, 2013
    #10
    I was able to make it work by clicking on "Tools" the "Language" and unchecking the "do not check spelling" box. You're also given the option to make that selection your "default". Otherwise I assume the same problem will happen again.

    Leave it to Microsoft to put the "check or don't check" box under Language rather than Spelling.
     

Share This Page